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This document is provided to customers who have purchased Molecular Devices 
equipment, software, reagents, and consumables to use in the operation of such 
Molecular Devices equipment, software, reagents, and consumables. This document 
is copyright protected and any reproduction of this document, in whole or any part, 
is strictly prohibited, except as Molecular Devices may authorize in writing.
Software that may be described in this document is furnished under a non-
transferrable license. It is against the law to copy, modify, or distribute the software 
on any medium, except as specifically allowed in the license agreement. 
Furthermore, the license agreement may prohibit the software from being 
disassembled, reverse engineered, or decompiled for any purpose.
Portions of this document may make reference to other manufacturers and/or their 
products, which may contain parts whose names are registered as trademarks and/or 
function as trademarks of their respective owners. Any such usage is intended only to 
designate those manufacturers’ products as supplied by Molecular Devices for 
incorporation into its equipment and does not imply any right and/or license to use 
or permit others to use such manufacturers’ and/or their product names as 
trademarks.
Each product is shipped with documentation stating specifications and other 
technical information. Molecular Devices products are warranted to meet the stated 
specifications. Molecular Devices makes no other warranties or representations 
express or implied, including but not limited to, the fitness of this product for any 
particular purpose and assumes no responsibility or contingent liability, including 
indirect or consequential damages, for any use to which the purchaser may put the 
equipment described herein, or for any adverse circumstances arising therefrom. The 
sole obligation of Molecular Devices and the customer's sole remedy are limited to 
repair or replacement of the product in the event that the product fails to perform as 
warranted.
For research use only. Not for use in diagnostic procedures. 
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Introduction
The MetaXpress® High Content Image Acquisition & Analysis Software is 
divided into two major parts: 

• Acquisition involves configuring settings, acquiring images, and 
storing plate data in a database. For information about image 
acquisition, see the user guide for the ImageXpress® Micro 
Widefield High Content Screening System or the ImageXpress® 
Micro Confocal High Content Screening System. Both user guides 
are provided on the MetaXpress Software installation media and 
are available in the Molecular Devices knowledge base at 
http://www.moleculardevices.com/support.

• Analysis consists of selecting, measuring, assessing, and 
managing acquired images and plate data.

In addition to this introduction, this guide describes the topics that are 
pertinent to the general analysis workflow:

• Chapter 2: Before You Start Your Analysis on page 11
• Chapter 3: Selecting and Analyzing Plates on page 13
• Chapter 4: Viewing Analysis Results on page 49
• Chapter 5: Application Modules on page 67
• Chapter 6: Custom Modules on page 93
• Chapter 8: Automating and Monitoring an Analysis on page 107
• Chapter 9: Batch Analysis on page 115
• Chapter 10: Managing Plate Data on page 119
5039429 C 7 
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Simplified Menu Structure
An optional simplified menu structure can be installed to reduce the 
number of top-level menus. All the features of the MetaXpress Software 
are available in this reorganized menu structure.
The procedures in this guide describe both the default menu structure 
and the simplified menu structure.
You can use the Menu Map in the Help menu to help you find the 
locations of features in the simplified menu structure.

1. Click Help > Menu Map.
2. In the Menu Map dialog, select to view the Default to 

customized menu map.
3. Click the menu path where the software feature you want is 

found in the default menu structure. 
The simplified menu path appears to the right of the desired 
feature in the menu.

4. Click the menu path in the software window to access the 
desired feature.

For example, if you want to make a duplicate of an image, then use the 
following procedure:

1. Click Help > Menu Map.
2. In the Menu Map dialog, select to view the Default to 

customized menu map.
3. Click Edit > Duplicate. 

The simplified menu path -> Edit: Image: Duplicate Image/Plane 
appears to the right of the Image option in the submenu.

4. In the software window, click Edit > Image > Duplicate 
Image/Plane.
8 5039429 C 
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Obtaining Support
Molecular Devices is a leading worldwide manufacturer and distributor 
of analytical instrumentation, software, and reagents. We are committed 
to the quality of our products and to fully supporting our customers with 
the highest possible level of technical service.
Our support web site, http://www.moleculardevices.com/support, has a 
link to the Knowledge Base with technical notes, software upgrades, 
safety data sheets, and other resources. If you do not find the answers 
you are seeking, follow the links to the Technical Support Service Request 
Form to send an email message to a pool of technical support 
representatives.
You can contact your local representative or contact Molecular Devices 
Technical Support by telephone at 800-635-5577 (U.S. only) or 
+1 408-747-1700. In Europe call +44 (0) 118 944 8000.
Part of effective communication with Molecular Devices is determining 
the channels of support for the ImageXpress System, including the 
MetaXpress Software. Molecular Devices provides a wide range of 
support:

• Documentation: Check the guides that are included on the 
installation media and the help that is available within the 
MetaXpress Software. Help for an active dialog can be accessed 
by pressing F1 on your keyboard.

• Online knowledge base: The knowledge base has links to 
technical notes, software upgrades, newsletters, user guides, 
and other resources. Visit the Molecular Devices Support web 
page at http://www.moleculardevices.com/support and follow 
the links to the knowledge base.

• MetaMorph Software forum: This forum has information on 
journal scripts and custom modules, and has links to videos and 
webinars that can help you troubleshoot problems and be more 
productive using the software. Visit the forum at 
metamorph.moleculardevices.com/forum.
5039429 C 9 
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• Technical Support:
Phone: Contact Technical Support at (800)-635-5577 (U.S. only) 
or +1 408-747-1700. In Europe call +44 (0) 118 944 8000.
Online: Visit http://www.moleculardevices.com/support and 
follow the links in the knowledge base to the Technical Support 
Request Form to send an email to a group of experienced 
Technical Support representatives.
Please have the system ID number, system serial number, 
software version number, and the name of the system owner 
available when you call.
 To find your system ID number, in the MetaXpress Software, 

click Help > About MetaXpress. The About dialog displays 
your system ID number.

 The system serial number is located on your instrument.
• Additional support resources include:
 Nikon web-based microscopy course: 

http://www.microscopyu.com 
 The Molecular Probes Handbook: 

http://www.lifetechnologies.com/us/en/home/references/
molecular-probes-the-handbook.html 
This resource offers advice on fluorescent probes and can 
help you determine if there are better stains available for 
your analysis.

 The following sites offer filter information: 
- http://www.semrock.com 
- http://www.chroma.com 
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Before You Start Your Analysis
When preparing to analyze plates, consider the following plate 
characteristics:

• Available wavelengths
Some application modules require certain stains and a specific 
number of wavelengths for analysis. Other modules analyze 
plates with a single wavelength, or with a flexible number of 
wavelengths. In addition, some modules can analyze transmitted 
light images, which have dark objects on a light background, 
while others expect fluorescent images, which have light objects 
on a dark background. If you are planning on using a particular 
analysis module, check the requirements for the module and 
verify that it is suitable for your assay.

• Cell or Object Identification
To obtain a cell count, or measure features on a cell-by-cell basis, 
the analysis module must identify the individual cells. The most 
common and generally, the most reliable method is to use a 
nuclear stain. Other stains or transmitted light can be used, but 
sometimes this can require a custom module or journal.

• Features of Interest
If subcellular features must be identified, then they should have 
a distinct appearance in the images that are being analyzed. 
Commercial stains are available for various subcellular organelles 
(for example, mitochondria) and these can be helpful to include 
in your assay when trying to analyze these features. 

• Measurements of Interest
One of the most important considerations in designing an 
analysis is selecting the measurements of interest. Ideally, the 
selected measurements should clearly distinguish the different 
possible phenotypes that are expected from the experiment. 
Sometimes, you might not know ahead of time which specific 
measurements will give the best results. For example, when 
measuring objects that change size with treatment, is the most 
useful measurement the area, the perimeter, or the length and 
breadth? And over a population of cells, should you compare the 
average area of all the cells, or the percentage of cells that fall 
within a certain size range? If you are unsure, then run some 
5039429 C 11 
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tests using known controls and generate all the available 
relevant measurements to determine which ones give the most 
consistent results before scaling up to a large screen.

• Statistics
Verify that your assay has a sufficient sample size to give you 
statistically significant results. Are you sampling enough of cells 
per well, and enough of replicates per treatment? If the event 
that you are observing is rare (affects a low percentage of cells), 
then you might need an increased sample size.

• Data Storage Requirements
When reviewing analysis results, do you need to view results for 
each individual cell, or only summary data for the site? Do you 
need to store the segmentation overlay for all your plates? Cell-
by-cell data and segmentation overlays can require a significant 
amount of database space, and should be saved only when 
required. In general, Molecular Devices recommends using these 
options during assay development, but not during screening 
unless it is essential for your particular assay.

• Throughput Needs
If you are analyzing many images, then analysis throughput can 
be important to you. Keeping the analysis as simple as possible 
helps to improve the analysis speed. Consider using the optional 
MetaXpress PowerCore Software, which uses parallel processing 
to significantly accelerate image analysis using either application 
modules or custom modules. 

• Plate to Plate Variation
If you must compare results across plates or across time, then it 
is important to control for variation in staining intensity, cell 
density, and other assay parameters that can vary from plate to 
plate. Make sure that the appropriate positive and negative 
controls are included on each plate, and that your analysis 
settings will measure these assay parameters.
12 5039429 C 
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Selecting and Analyzing Plates
The first step in the image analysis process is to select the plate in the 
database that contains the images to analyze. You can then view and 
arrange the images in various ways to examine and compare them to 
decide which wells in the plate are appropriate for analysis, and how you 
might need to analyze the wells. For example, you can specify the 
wavelengths to display in the images, combine wavelengths into a 
composite image, and display information such as the well number on 
the images. You can also scale 16-bit images and generate an intensity 
profile to help you determine the areas of the image that have the 
highest intensity. Based on all the information that you collect from 
arranging and viewing the images, you can select the appropriate wells 
for analysis. Finally, after you select the appropriate wells in the plate, 
you analyze the selected wells.

This chapter includes the following topics:
• Selecting a Plate for Analysis on page 14
• Viewing and Arranging Images on page 17
• Selecting Wells for Analysis on page 34
• Running an Analysis on page 34

Note: The settings that you use to select and view images for analysis 
in the Review Plate Data dialog are for display purposes only and 
cannot be saved to a settings file. They do not affect image analysis or 
other measurements and cannot be saved and reused. 

Settings that are made in an application module dialog (described in 
Chapter 6: Configuring Application Modules on page 55) define the 
characteristics that are specific to the selected application module. 
These application module settings can be saved and reused.
5039429 C 13 
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Selecting a Plate for Analysis

1. Click Screening > Review Plate Data.
In the simplified menu structure, click Screening > Review Plate.

2. In the Review Plate Data dialog, click Select Plate.
3. In the Select Plate for Review dialog, expand the plates folder in 

the top pane to view the subfolders that contain plates that have 
been saved in the database.

Note: For information about using the Review Plate Data dialog, see 
the video: https://www.youtube.com/watch?v=ks4UKc8vq-A.

Tip: To select the information such as a barcode or plate 
description by which to organize the subfolders and plates, click 
the Configure Branches button in the upper-right corner of the 
dialog.
14 5039429 C 
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4. Double-click a subfolder in the top pane to display its contents in 
the middle pane.

5. In the middle pane, select a plate, and then click Select.

The Review Plate Data dialog opens. The Run Analysis tab is the 
open tab. The image data for the selected plate is displayed in 
the dialog.

6. Click the Display tab, and then continue to Viewing and 
Arranging Images on page 17.

Tip: After you select a plate, default information about the 
selected plate is displayed in the bottom pane of the Select Plate 
for Review dialog. To add or modify the information that is to be 
displayed for a selected plate, click the Configure Displayed 
Columns button in the upper-right corner of the dialog.
5039429 C 15 
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Tip: After you load a plate into the Review Plate Data dialog, as 
long as the plate images have not been imported, you can click 
Export Settings to export the protocol settings that were used to 
acquire the plate to an .hts file. You must name the file and 
select the location in which to save the file. You can then select 
this saved protocol file when acquiring data for other plates. 
16 5039429 C 
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Viewing and Arranging Images

In the Review Plate Data dialog, you use the Plate map and the options 
on the Display tab to view, arrange, and then ultimately select images for 
analysis. Each square in the Plate map represents a single well in a plate. 
Markings, color highlighting, or shading are used to indicate the 
following:

• Wells that are marked with a hyphen (-) indicate that the wells 
contain image data.

• Wells that are highlighted in gray indicate wells that are 
displayed in a Montage window.

• Wells that are highlighted in bright green indicate wells that have 
been selected for analysis.

• Wells that are highlighted in dark green indicate wells that are 
included in the Montage window and that have also been 
selected for analysis.

• A well that is outlined in red indicates a well that is being 
displayed in its own individual image window.
For example:

The Data view drop-down list at the top of the Plate map is useful for 
arranging images according to time points and measurements after you 
have run an analysis on the images. Before analysis, the Plate map is 
arranged in the same order that the wells are arranged in the microwell 
plate (Well arrangement).

1. In the Review Plate Data dialog, in the Wavelengths section, 
select one or more wavelengths to display in the images. 

2. Do one or more of the following on the Display tab as needed to 
help in the viewing and arranging of images. See:
 Selecting wells for the Montage window and viewing well 

images in a Montage window on page 18.
 Viewing and arranging images for multi-site wells on 

page 20.
 Generating a 3-D intensity profile graph on page 20.
 Assigning colors to acquisition wavelengths on page 21.
5039429 C 17 
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 Creating a composite image on page 21.
 Scaling 24-bit color composite images on page 22.
 Auto scaling of 16-bit single wavelength images for display 

on page 22.
 Viewing time point data on page 24.
 Viewing Z series images on page 28.
 Collating the images of multiple wells on page 33.

Selecting wells for the Montage window and viewing 
well images in a Montage window
You can view a thumbnail for each well in a plate in a Montage window 
and compare the overall density and distribution of the sample material 
in each well. Samples showing an overall high density and even 
distribution are generally better candidates for analysis than wells with 
very low sample density and uneven distribution. To select a well or wells 
for displaying in the Montage window, do any of the following as needed:

• To select a single well in a plate for the Montage window, click 
once on the appropriate square in the Plate map. 

• To select multiple wells in a plate for the Montage window, click 
and hold the left mouse button, and then drag the cursor over 
the appropriate wells in the Plate map.

• To select all the wells in a plate for the Montage window in a 
single step, click in the upper left corner of the Plate map (the 
blank cell between “A” and “01”).
The Montage windows that open are labeled HTS- followed by 
the name of the stain or wavelength that you assigned to the 
wavelength; for example, HTS-DAPI or HTS-FITC. If you are 
viewing a color composite image, then the window is labeled 
HTS-Encoded.

Note: The montage dimensions that are displayed in the Montage 
fields determine the total number of sites that are displayed across all 
the wells that have been selected for inclusion in the montage. 
Molecular Devices recommends that you do not manually adjust these 
values. Instead, allow the MetaXpress software to automatically adjust 
these dimensions as you select or de-select wells.
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You can open an image in a Montage window in a separate window at full 
resolution. To do so, click the image in the Montage window or right-click 
the appropriate well in the Plate map. For example, the following figure 
shows the image for well D10 in the Montage window. If you click D10 in 
the Montage window, the full resolution image opens in a separate 
window.

To display images in the Montage window for a different group of wells, 
do one of the following:

• Click another well in the Plate map to indicate the top left well in 
the new group.

• Use the left or right arrow beneath the lower right corner of the 
Plate map to move the group of selected wells. 

The group of wells that is selected has the same number of wells (rows 
and columns) as the wells that were originally selected for the montage.
To toggle the display of the well number in the Montage window, select 
Show well information/No overlay display on the Image Overlay drop-
down list. To change the color of the well number in the Montage 
window, select a different color on the Col drop-down list.

Note: If you right-click a well, then the well is outlined in red and 
highlighted in green to indicate that is selected for analysis. To de-select 
the well for analysis, right-click it again.
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Viewing and arranging images for multi-site wells
If images were acquired at multiple sites in the wells in a plate, then a 
Sites section is displayed to the left of the Plate map. The Sites graphic 
indicates the sites for each well for which data was acquired as specified 
on the Sites to Visit tab on the Plate Acquisition Setup dialog. If data was 
not acquired for a specified site, then a blank white pane is displayed for 
site in the graphic. If data was acquired for a site, then a hyphen (-) is 
displayed. For example, in the following graphic, data was acquired for 
only four of the six sites that were visited in each well.

If images were acquired at multiple sites in a well, then: 
• Click any available site in the Sites section to view only this site 

for all selected wells in the Montage window. 
• Click All Sites to view all sites for all selected wells in the 

Montage window.

Generating a 3-D intensity profile graph
To transform the image into a three-dimensional intensity profile graph, 
select Intensity Profile. The MetaXpress Software uses the colors that 
are assigned to the image and displays the highest intensities as the 
highest peaks in the graph.

Note: If you select All Sites, then the MetaXpress software 
automatically adjusts the Montage dimensions to display all the 
sites in the selected wells in the Montage window.
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Assigning colors to acquisition wavelengths
You can assign a color to each acquisition wavelength in your data set. 
How you assign colors depends on whether your images were acquired 
with a single wavelength or with multiple wavelengths.

• For single wavelength images, select an appropriate LUT on the 
image window.

• For multi-wavelength images, select the appropriate wavelength 
on the Source R (red), G (green), or B (blue) drop-down list on 
the Review Plate Data dialog. 

Creating a composite image
To combine images that were acquired with multiple wavelengths into a 
single composite image, select Color Composite. If images were acquired 
with multiple wavelengths, and Color Composite is not selected, then a 
separate Montage window displays the images for each wavelength that 
is selected in the Wavelengths section. Use the Toggle Channel Color 
buttons to turn on and off wavelengths as needed.

Note: If Color Composite is selected but all colors are set to [None] for 
Source, then no images are displayed for the plate and there are no 
error messages.
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Scaling 24-bit color composite images
To manually define a range for scaling 24-bit color composite images, 
clear Auto Scale, and then in the Range field, select the upper range for 
the scaling.

Auto scaling of 16-bit single wavelength images for 
display
Auto Scale automatically adjusts the scaling based on the minimum and 
maximum intensities in an image. By default, when you open an image in 
the MetaXpress Software, Auto Scale is turned on. This is indicated by 
the letter “A” displayed in the Image Scale button on the toolbar of a 
Montage window, or an individual image window. With Auto Scale 
turned on, pixels in the upper 1% of the intensity range are assigned the 
maximum possible intensity (generally 65,535) and pixels in the lower 1% 
of the intensity range are assigned the minimum possible value (0, or 
black), therefore making the image brighter on the display. 

Tip: Although the Color Composite option is helpful for reviewing 
images, it does not produce the best quality images for presentation or 
publication. For better quality images, clear Color Composite, open 
single wavelength full resolution images for the site of interest, and 
then use the Overlay Images function (Display > Overlay Images in the 
default menu or Edit > Display > Overlay Images in the simplified 
menu).

Note: Color Composite must be selected for scaling. To automatically 
scale 24-bit color composite images, select Auto Scale.
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When comparing different objects between multiple images, it is not 
helpful to have Auto Scale turned on, as both bright and dim samples 
appear with the same brightness.

If Auto Scale is turned off, only then do the objects or images appear with 
their true intensity levels.
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When comparing the intensity levels of objects across multiple images, 
turn off Auto Scale and use the Image Scaling sliders to adjust the image 
display, as shown in the following figure:

• Drag the top Image Scale slider to set the intensity at which 
images are turned brighter (white) or dimmer (black). Moving 
the top slider up turns the image darker. Conversely, moving the 
top slider down turns the image brighter. 

• Drag the bottom Image Scale slider to set the intensity at which 
the background is turned brighter (white) or dimmer (black). 
Moving the bottom slider up turns the background darker 
(black). Conversely, moving the bottom slider down turns the 
background brighter (white).

Viewing time point data
If you have acquired data for time point experiments, then multiple 
options are available for viewing this data. You can:

• View a thumbnail montage of multiple wells at a single time 
point. See To view a thumbnail montage of multiple wells at a 
single time point on page 25.

• View multiple wells at multiple time points. See To view multiple 
wells at multiple time points on page 25.

• View high-resolution images from selected wells/time points. 
See To view high-resolution images from selected wells or time 
points on page 26.

• View time points for a single site/well as a stack. See To view a 
stack (.stk) file of a series of time points from one site/well on 
page 27.
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To view a thumbnail montage of multiple wells at a single time 
point

1. In the Data view field, select Well arrangement.
2. In the Time points field, select the appropriate time point; for 

example, 3 of 5.
3. Select the wells that are to be displayed in the Montage window. 

See Selecting wells for the Montage window and viewing well 
images in a Montage window on page 18.

The well ID/time point for each selected well is displayed in the 
upper left corner of each thumbnail image in the Montage 
window; for example, A01t3, B01t3, and so on.

To view multiple wells at multiple time points
1. In the Data view field, select Time Point vs Well to change the 

layout of the Plate map. (The time points are displayed in the “X” 
direction and the well IDs are displayed in the “Y” direction.)

Note: You might need to use the scroll bars in the Sites graphic 
to scroll to a site to select it.
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2. Select the wells that are to be displayed in the Montage window, 
which tiles the images at each time point in a filmstrip-like 
format across the montage. See Selecting wells for the Montage 
window and viewing well images in a Montage window on 
page 18.

The well ID/time point for each selected well is displayed in the 
upper left corner of each thumbnail image in the Montage 
window; for example, A01t3, A01t2, and so on.

To view high-resolution images from selected wells or time points
Click any low-resolution thumbnail image in an existing montage to open 
the corresponding high-resolution image set. 

Note: You might need to use the scroll bars in the Sites graphic 
to scroll to a site to select it.
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To view a stack (.stk) file of a series of time points from one 
site/well

1. In the Data view field, select Time Point vs Well to change the 
layout of the Plate map. (The time points are displayed in the “X” 
direction and the well IDs are displayed in the “Y” direction.)

2. Do one of the following:
 If only a single site per well was acquired, then right-click a 

single well of interest (for example, C18) in either the Plate 
map or a thumbnail in the Montage window.

 If multiple sites per well were acquired, de-select All Sites, 
select the site of interest, and then right-click a single well of 
interest (for example, C18) in either the Plate map or a 
thumbnail in the Montage window.

3. Click Load Selected Images.
The well ID/time point for each selected well is displayed in the 
upper left corner of each thumbnail image in the Montage 
window; for example, A01t1, A01t2, and so on.

4. After you have created a stack file of a series of time points from 
one site or well, you can use the image slider or the playback 
controls at the top of a stack window to scroll through the 
images in the stack.

Note: If needed, to clear all selected wells, click Clear Selection.
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Viewing Z series images
If you have acquired Z series images for experiments, then multiple 
options are available for viewing this data. You can:

• View a 2D projection image for the Z series. See To view a 2D 
projection image for the Z series.

• View a thumbnail montage of multiple wells at a single Z step. 
See To view a thumbnail montage of multiple wells at a single Z 
step on page 29.

• View multiple Z steps from a single well or multiple wells. See To 
view multiple Z steps from a single well or multiple wells on 
page 30. 

• View a series of Z steps for a single site/well as a stack. See To 
view a stack (.stk) file of a series of Z steps from one site or well 
on page 31.

• View high resolution, single Z step images. See To view high 
resolution, single Z step images on page 32.

To view a 2D projection image for the Z series
1. In the Data view field, select Well arrangement.
2. Select 2D projection.
3. Select the wells that are to be displayed in the Montage window. 

See Selecting wells for the Montage window and viewing well 
images in a Montage window on page 18.
The well ID/2D projection for each selected well—always labeled 
as well ID/z0—is displayed in the upper left corner of each 
thumbnail image in the Montage window, for example, D04z0.
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To view a thumbnail montage of multiple wells at a single Z step
1. In the Data view field, select Well arrangement.
2. In the Z steps field, select the appropriate Z step, for example, 12 

of 16.
3. Select the wells that are to be displayed in the Montage window. 

See Selecting wells for the Montage window and viewing well 
images in a Montage window on page 18.
The well ID/Z step for each selected well is displayed in the upper 
left corner of each thumbnail image in the Montage window, for 
example, A01z12, B01z12, and so on.
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To view multiple Z steps from a single well or multiple wells
1. In the Data view field, select Z Step vs Well to change the layout 

of the Plate map. (The Z steps are displayed in the “X” direction 
and the well IDs are displayed in the “Y” direction.)

2. Do one of the following:
 To select a single well, click and drag your cursor across 

the Z Steps Plate map for the well. You can select a 
subset of Z steps, or the full Z step course.

 To select multiple adjacent wells, click and drag your 
cursor over the appropriate range of wells.

As shown in the following figure, images at each Z step are tiled 
in a filmstrip-like format across the montage. The well ID/Z step 
for each selected well is displayed in the upper left corner of 
each thumbnail image in the Montage window, for example, 
A01z1, A01z2, and so on.
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To view a stack (.stk) file of a series of Z steps from one site or 
well

1. In the Data view field, select Z Step vs Well to change the layout 
of the Plate map. 
The Z steps are displayed in the “X” direction and the well IDs are 
displayed in the “Y” direction.

2. Do one of the following:
 If only a single site per well was acquired, then right-click a 

single well of interest (for example, C18) in either the Plate 
map or a thumbnail in the Montage window.

 If multiple sites per well were acquired, de-select All Sites, 
select the site of interest, and then right-click a single well of 
interest (for example, C18) in either the Plate map or a 
thumbnail in the Montage window.

3. Click Load Selected Images.
The well ID/Z step for each selected well is displayed in the upper 
left corner of each thumbnail image in the Montage window, for 
example, A01z3, B01z3, and so on.

Note: If needed, to clear all selected wells, click Clear Selection.
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4. After you have created a stack file of a series of Z steps from one 
site/well, you can use the image slider or the playback controls 
at the top of a stack window to scroll through the images in the 
stack.

To view high resolution, single Z step images 

Click any low-resolution thumbnail image in an existing montage to 
display the corresponding high-resolution image set.
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Collating the images of multiple wells
To collate the images of multiple wells into one window that you can 
scroll through and save as a stack (.stk) or as a multi-plane TIF (.tif) file, 
do the following:

1. In the Plate map, select the appropriate wells.
 To select a single well, right-click the well in the Plate map. 

Repeat this step to de-select the well.
 To select multiple wells, click and drag your cursor over the 

appropriate wells in the Plate map. Repeat this step to de-
select the wells.

 To select all the wells in a plate in a single step, click in the 
upper left corner of the Plate map (the blank cell between 
“A” and “01”). To de-select all wells at once, repeat this step. 

2. Click Load Selected Images.
A stack is created for each selected wavelength and displayed in 
an individual Selected (stack) window or, if Color Composite is 
selected, a single stack is created and displayed in a single 
Selected (stack) window. If All Sites is selected, then the stack 
contains the images for all sites in all selected wells.

3. Do any of the following as needed:
 To navigate through the images in the stack, drag the slider 

at the top of the Selected (stack) window. 
 To clear all selected wells, click Clear Selection.
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Selecting Wells for Analysis
Based on all the information that you collect from arranging and viewing 
the images, you can then select the appropriate wells for analysis. Wells 
that are selected for analysis are highlighted in a bright green. To select 
wells for analysis, do the following:

• To select a single well for analysis, right-click the well in the Plate 
map. Repeat this step to de-select the well for analysis.

• To select multiple wells for analysis, press and hold the Control 
key or the Shift key, click and hold the left mouse button, and 
then drag the cursor over the appropriate wells in the Plate map. 
Repeat this step to de-select the wells for analysis.

• To select all the wells in a plate for analysis in a single step, press 
and hold the Control key or the Shift key, and then click in the 
upper left corner of the Plate map (the blank cell between “A” 
and “01”). To de-select all wells for analysis, repeat this step. 

The following functions on the Display tab are applicable for these wells: 
Load Selected Images and Navigate Selections. The Run on selection 
function on the Run Analysis tab is also applicable for these wells. 

Running an Analysis
After you select the appropriate wells in the plate, you analyze the 
selected wells. In most circumstances, despite the automated 
capabilities, manually run preliminary tests on one or more wells, such as 
both positive and negative controls, to ensure valid results.

1. On the Analysis drop-down list on the Run Analysis tab of the 
Review Plate Data dialog, select an application module, a 
custom module, or a journal.

Note: If the appropriate application module is not available, 
then you can create a custom module, or you can import a 
custom module. For information about creating a custom 
module, see Chapter 6: Custom Modules on page 93. For 
information about importing a custom module, see Importing a 
Custom Module on page 38. For assistance in developing or 
importing a journal, contact technical support. If the appropriate 
analysis journal is not available, then you can add it to the 
database. See Chapter 7: Journals on page 97.
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2. Do one of the following:
 To use an existing Settings file, on the Settings drop-down 

list, select the file. 

 To create an entirely new Settings file for an application 
module, see Configuring the Settings file on page 72 in 
Chapter 5: Application Modules on page 67.

 To modify an existing Settings file for an application module 
before using it, or import a needed Settings file for an 
application module, then click Edit List to open the Edit List 
of Settings dialog, and then continue to Working with a 
Settings file on page 40.

3. Optionally, to log the measurement data from your analysis into 
the database, select Log into the database.

Note: You must select a file that has the correct settings based 
on the wavelengths that were used to acquire the plate.
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4. If you are running a custom journal, or if the plate contains 
multiple time points, or Z step data, then do any of the following 
as applicable. Otherwise, continue to Step 5.
 If you are running a custom analysis that is derived from a 

journal and you have created a setup journal for it, then click 
Run Setup for Analysis to run the setup journal. 

• If the plate contains multiple time points, then select from the 
Time points options.
 All time points: Analyzes all the acquisition time points.
 Time point range: Analyzes only those acquisition time 

points that fall within in the defined range. To use a single 
time point, type the same value in both fields.

 Selected time point: Analyzes the currently selected time 
point. 

 Stack of all time points: Available when you select a time 
lapse journal that analyzes planes in a stack as separate time 
points.

Note: The setup journal must be in the same folder as the main 
analysis and must be named in the format: 
EXAMPLEJOURNAL_SETUP.JNL. See Adding a 
Setup Journal to the MetaXpress Software 
Database on page 104.

Note: Well arrangement must be selected for Data view to 
show the currently selected time point in the Time points field. 
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• If the plate contains Z data, then select from the Z steps options.
 All Z points: Analyzes all the acquisition planes.
 Z step range: Analyzes only those planes that fall within the 

defined range. To use a single Z step, type the same value in 
both fields.

 Selected Z step: Analyzes the currently selected Z step.

 Stack of all Z steps: Available only if the selected analysis is a 
journal.

 2D projection: Analyzes only the two-dimensional projection 
image.

5. To analyze the data, select one of the following options:
 Click Run on all wells to run the assay for all sites in all wells 

on the plate.

 Click Run on selection to run the assay on all sites in all 
selected wells. 

 Click Run on displayed site to run the assay for the currently 
selected site. 

6. After the analysis is run, view the results in the Cellular Results 
table, on the Measurements tab, or on the Graph tab. See 
Chapter 4: Viewing Analysis Results on page 49 for more 
information.

Note: Well arrangement must be selected for Data view to 
show the currently selected Z step in the Z steps field. 

Note: You can select this option with or without all wells in the 
Plate map selected for analysis.

Note:  To run an analysis on only certain sites in the selected 
wells, you must use a journal. 

Note: This option requires an opened high-resolution single 
image file for each wavelength that is analyzed.
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Importing a Custom Module
Any custom module that was created in the current MetaXpress Software 
database, even if from a different computer, is always available on the 
Analysis drop-down list on the Run Analysis tab on the Review Plate 
Data dialog. You can use the Import Custom Module and Export Custom 
Module options to move a custom module between databases.

1. On the Screening menu, select Add Custom Module to 
Database.

Note: For information about using the Custom Module Editor to create 
a custom module, and export a custom module, see Chapter 6: Custom 
Modules on page 93 or the help for the Custom Module Editor.

Note: To delete a custom module, you must delete all Settings files for 
the module. After you delete a custom module, it is no longer displayed 
on the Analysis drop-down list on the Run Analysis tab of the Review 
Plate Data dialog. See Deleting a Settings File on page 45.
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2. In the Add Custom Module to Database dialog, click Select 
Custom Module File.

3. In the Select Custom Module dialog, browse to and select the 
custom module file (the .xml file) that is to be imported, and 
then click Open.

4. In the Custom Module Editor dialog, under Settings, do one of 
the following:
 To add the custom module file as a new file, leave Add New 

(the default value) selected, and then in the Setting Name 
field, type the name of the new custom module file.

 To overwrite the existing custom module file in the database, 
select Overwrite existing. The Setting Name field is 
automatically populated with the name for the selected 
custom module file.

5. Optionally, in the Custom Module description field, type a 
description for the custom module file.

6. Do one of the following:
 If you are adding the custom module as a new file, then click 

Add.
 If you are overwriting an existing custom module, then click 

Overwrite.
7. At the prompt that indicates that the module was successfully 

added or overwritten, click OK to close the prompt and the Add 
Custom Module to Database dialog.
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Working with a Settings file
When running an analysis, you can create a new Settings file for an 
analysis, or you can select an existing Settings file. Options are also 
available for creating a new Settings file for analysis by modifying an 
existing file, modifying an existing Settings file for an analysis, or 
importing an existing Settings file for an analysis. You can also rename a 
Settings file, delete a Settings file, and export a Settings file.

See:
• Creating a Standard Application Module Settings File by 

Modifying an Existing Settings File.
• Modify an Existing Standard Application Module Settings File on 

page 42.
• Importing an Existing Standard Application Module Settings File 

on page 43.
• Renaming a Settings File on page 44.
• Deleting a Settings File on page 45.
• Exporting a Settings File in its Current State on page 46.
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Creating a Standard Application Module Settings File by 
Modifying an Existing Settings File
When you create a new Settings file for a standard application module by 
modifying an existing file, the settings for the original Settings file remain 
untouched. Both the original Settings file and the newly created Settings 
file are displayed in the Settings pane on the Edit List of Settings dialog.

1. Make sure that the appropriate application module is selected 
on the Analysis drop-down list.

2. Click Edit List.
3. In the Edit List of Settings dialog, in the Settings pane, select the 

appropriate Settings file.
4. Click New Settings.

5. In the New Settings dialog, type the name for the new Settings 
file, and then click OK.

6. In the Configure Settings dialog, modify the analysis settings as 
required, and then click Close. See Configuring the Settings file 
on page 72.
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Modify an Existing Standard Application Module 
Settings File
When you modify the settings for an existing Settings file, any analyses 
that were done with the original settings are unaffected. Going forward, 
the settings are applicable only for new analyses. If required, you can 
also just modify the description for an existing Settings file. 

1. Make sure that the appropriate application module is selected 
on the Analysis drop-down list.

2. Click Edit List.
3. In the Edit List of Settings dialog, in the Settings pane, select the 

appropriate Settings file.
4. Optionally, in the Edit List of Settings dialog, edit the description 

for the Settings file.

5. Click Configure Settings.

6. In the Configure Settings dialog, modify the analysis settings as 
needed. See Configuring the Settings file on page 72.

7. Click Save Settings.

Tip: To modify only the description for the Settings file, and no 
other values, then click Close on the Edit List of Settings dialog 
and return to the Review Plate Data dialog.
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8. Click OK to close the Save Settings dialog, and save the Settings 
file with the modified settings.

Importing an Existing Standard Application Module 
Settings File
You can import an existing Settings file only for a standard application 
module. The Settings files that are available for importing depend on the 
selected application module. When you import a Settings file for a 
standard application module, it is imported into the database for the 
MetaXpress instance. After you import a Settings file, it is available for 
selection on the Analysis drop-down list on the Run Analysis tab of the 
Review Plate Data dialog.

1. Make sure that the analysis for which you are importing the 
settings is selected on the Analysis drop-down list.

2. Click Edit List.
3. In the Edit List of Settings dialog, click Import Settings.

Note: To import a custom module, see Importing a Custom Module on 
page 38. To add a journal, see Chapter 7: Journals on page 97.
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4. In the Import Assay Settings dialog, browse to and select the 
appropriate Settings file, and then click Open.

Renaming a Settings File
1. Make sure that the analysis for which you are renaming the 

Settings file is selected on the Analysis drop-down list.
2. Click Edit List.
3. In the Edit List of Settings dialog, in the Settings pane, select the 

appropriate Settings file.
4. Click Rename Settings.

5. In the Rename Settings dialog, type the modified name for the 
Settings file, and then click OK.
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Deleting a Settings File
When you delete a Settings file, any analyses that were done with the 
original settings are unaffected. Going forward, the Settings file is not 
available for selection for new analyses. 

1. Click Edit List.
2. In the Edit List of Settings dialog, in the Settings pane, select the 

appropriate Settings file.
3. Click Delete Settings.

4. In the Delete Settings dialog, click Yes to delete the selected 
Settings file.

CAUTION! If you delete all Settings files for a custom module or a 
journal, then the module or the journal is deleted from the Analysis 
drop-down list.
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Exporting a Settings File in its Current State
The Export Settings option on the Edit Settings List dialog exports the 
Settings file in its current state - that is, the settings that are currently 
contained in the file. When you export a Settings file, the files are 
exported from the database to a default location of c:\assay, or you can 
select a different location. The Settings file is exported as named and 
with a set extension based on the module or journal that is associated 
with the file, and you cannot change either of these values.

1. Make sure that the analysis for which you are exporting the 
settings is selected on the Analysis drop-down list.

2. Click Edit List.
3. In the Edit List of Settings dialog, in the Settings pane, select the 

appropriate Settings file.
4. Click Export Settings.

5. In the Export Settings dialog, do one of the following:
 Leave the default location set to c:\assay.
 Click Browse and in the Browse for Folder dialog, browse to 

and select a different location to which to export the file, 
and then click OK.

Note: To export the Settings file with the settings that were actually 
used for the measurement of a plate, see Exporting the Settings File 
Used to Measure the Plate on page 60.
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6. Click OK.

7. In the Export Settings message dialog, click OK to close the 
message indicating that the file was successfully exported and 
return to the Edit List of Settings dialog.
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Viewing Analysis Results
The MetaXpress® Software provides several ways to review your analysis 
results, including image overlays, graphs, and heat maps. 
This chapter includes the following topics:

• Viewing Analysis Results on page 50
• Using the Cellular Results Table on page 53
• Filtering Data Analysis Values on page 55
• Generating a Heat Map for Analysis Results on page 56
• Viewing Image Overlay Information on page 59
• Exporting Selected Data on page 61
• Graphing Analysis Results on page 65

Note: In addition to the analysis review features of the MetaXpress 
Software discussed in this chapter, you can use the AcuityXpress 
Software for further visualization and investigation of your analysis 
results. Contact your Molecular Devices representative for more 
information about the AcuityXpress Software. 
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Viewing Analysis Results
After running an analysis, you can click Show Values on the Display tab 
to display the analysis results for each well in the Montage window and 
on the Plate map. Values in the Montage window and the Plate map are 
automatically updated based on a selected measurement. 

• If a single site is selected for display, then the value that is 
displayed for a well in the Montage window and the value that is 
displayed for the corresponding well in the Plate map are 
identical. 

• If all sites are selected for display, then the individual values are 
displayed for the sites in each well in the Montage window and 
the average of all the site values is displayed for the 
corresponding well in the Plate map. 

• If the selected measurement is a “Cell” measurement, then the 
values that are displayed in the Plate map are the average of all 
cells that were found in the well. 

1. On the Display tab of the Review Plate Data dialog, click Show 
Values.

2. Open the Measurements tab, and then do the following:
 On the Analysis drop-down list, select the appropriate 

analysis. 
 On the Measurement drop-down list, select the appropriate 

measurement.

Note: Measurements that are preceded by “Cell:” are cell-by-
cell data. To view cell-by-cell data for the selected site or well, 
use the Cellular Results table. See Using the Cellular Results 
Table.
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3. By default, analysis data is displayed in Well Arrangement (the 
plate format). Optionally, to change the Data view, select one of 
the following:

4. Continue to any of the following as needed for viewing and 
evaluating your data:
 Using the Cellular Results Table on page 53.
 Filtering Data Analysis Values on page 55.
 Generating a Heat Map for Analysis Results on page 56.
 Viewing Image Overlay Information on page 59.
 Exporting Selected Data on page 61.
 Graphing Analysis Results on page 65.

Table 4-1: Data view options for analysis results

Option Description

Time point vs well A matrix view of select measurements 
across all time points. Columns are time 
points and rows are well ID.

Z Step vs well A matrix view of select measurements 
across all Z steps. Columns are Z steps and 
rows are well ID.

Measurement vs well  A matrix view of all measurements for a 
single plane. Columns are measurements 
and rows are well ID.

Note: If you are viewing time lapse data or Z series data, then 
there are special considerations. See Viewing analysis results for 
time lapse experiments or Z step experiments on page 52.
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Viewing analysis results for time lapse experiments or Z 
step experiments
If you are viewing analysis results for time lapse experiments, or Z step 
experiments, then make note of the following:

• For time lapse experiments:
 If Well arrangement or Measurement vs well is selected for 

the Data view, then the data that is displayed is for the time 
point that is selected in the Time point fields.

 If a particular time point was not analyzed for the current 
measurement set, then no data is displayed when this time 
point is selected.

 To view the data from all time points (for example, to 
identify trends over time), select Time point vs well for the 
Data view.

• For Z step experiments:
 If Well arrangement or Measurement vs well is selected for 

the Data view, then the data that is displayed is for the Z step 
that is selected in the Z step fields.

 If a particular Z step was not analyzed for the current 
measurement set, then no data is displayed when this Z step 
is selected.

 If the 2D projection was selected for analysis, then select 2D 
projection to view the resulting data. If the analysis was 
done on the 2D projection, then each of the individual Z 
planes displays the results of the analysis on the projection. 
If the 2D projection was not analyzed, then no data is 
displayed when 2D projection is selected.

 To view the data from all Z steps (for example, to identify 
trends through the Z-stack), select Z Step vs well for the 
Data view. Data from the 2D projection is not available from 
this view.
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Using the Cellular Results Table
The Cellular Results table provides a quick way to correlate individual 
cells in an individual well plate image with data that is obtained from an 
application module. The data that is displayed in the Cellular Results 
table is the same data that is configured with the Configure Data Log 
(Cells) option for the application module that you are using, or with the 
Measure tab for the custom module that you are using. You are not 
required to have a data log open to view the Cellular Results table.

1. In the Plate map, make sure that you have a well selected for 
display in its own individual image window. 

2. If the Cellular Results table has not opened automatically after 
running an application module analysis, then in the Review Plate 
Data dialog on the Display tab, click Cellular Results.

3. Do one or both of the following as required to review the cellular 
data:
 Select one of the segmented cells in the image to highlight 

the corresponding data for the cell in the Cellular Results 
table.

 Select a row in the Cellular Results table to highlight the 
corresponding cell in the segmented image.

Note: Use Ctrl+Click to select multiple cells from the image. 

Note: Use Ctrl+Click to select multiple cells from the Cellular 
Results table. Use Shift+Click to select a range of cells from the 
table. 
5039429 C 53 



MetaXpress High Content Image Acquisition & Analysis Software Analysis Guide

MX_AnalysisGuide.book  Page 54  Wednesday, April 13, 2016  11:05 AM
4. Optionally, to prevent the Cellular Results table from opening 
each time an application module runs, clear Show Cellular 
Results.

Note: This segmentation is absent if Save segmentation 
overlay to database was not selected. See Viewing Image 
Overlay Information on page 59.

Note: If you clear Show Cellular Results, but later want to view 
the Cellular Results table when running an application module, 
click Window > Show Cellular Results. In the simplified menu, 
click Measure > Show Cellular Results.
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Filtering Data Analysis Values
Use the options in the Select Wells Based on Variable Range section to 
highlight wells that fit criteria that you specify for a selected 
measurement.

1. In the Review Plate Data dialog, open the Measurements tab.

2. On the Analysis drop-down list, select the analysis that contains 
the measurements that are to be filtered. 

3. On the Measurement drop-down list, select the measurement 
for which values are to be filtered.

4. In the Display Format field, select the number of decimal places 
that are to be displayed for your data.

5. Make sure that Show Heat Map is not selected.

6. In the Select Wells Based on Variable Range section, specify the 
criteria for automatically selecting wells. 

7. Click Select to highlight the wells that meet the criteria in green 
in the Plate map.

Tip: The Select Wells Based on Variable Range provides a means of 
carrying out a subpopulation analysis by automatically selecting wells of 
interest which you can then use with the Run Analysis for Selections 
option on the Run Analysis tab.

Note: If a heat map is enabled, selected wells on the grid 
cannot be distinguished; however, the selected wells are 
outlined in green on the thumbnail montage.
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8. Do either one or both of the following as needed:
 To clear the selection, click Clear Selection.
 To log the data that is displayed in the Plate map, and if 

applicable, the Cellular Results table, see Exporting Selected 
Data on page 61.

Generating a Heat Map for Analysis Results
Visual representation of a data in a heat map provides a simple way to 
quickly identify general patterns; for example, clusters of similar values. 
By default, the heat map uses a green-red color scheme and distributes 
all the measurement values on a linear scale. The lowest (“cold”) value is 
green, while the highest (“warm”) value is red. Measurements between 
the low and high ends are displayed with colors that correspond to the 
relative position of the values on the scale. You can distribute the data on 
a linear or logarithmic scale, set low and high thresholds, and change the 
color scheme. 

1. In the Data View field, select Well arrangement, and then on the 
Measurements tab, select Show Heat Map.

Note: If a heat map is enabled, selected wells on the grid 
cannot be distinguished; however, the selected wells are 
outlined in green on the thumbnail montage.
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2. Click Heat Map.
The Heat Map dialog opens.

3. Optionally, do one or more of the following:
 Select the type of scale that the heat map uses to distribute 

the data.
Table 4-2: Heat Map scale options

Option Description

Linear Distributes the data using the actual measurement 
values. This type of scale is ideal for data that does not 
cover a wide range of values.

Logarithmic Distributes the data on a logarithmic scale, starting with 
.0001 and exponentially increasing the values using a 
base of 10 (.0001, .001, .01, .1, 1, 10, 100, 1,000, 
10,000). 

Note: The logarithmic scale presents a wide range of 
data on a more manageable scale. The scale is useful 
when you want to analyze values that are at the lower 
end of a wide range of data. 
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 Select the method that the heat map uses to calculate the 
range of data, and then define the range.

 Select a different color scheme for the heat map.
 To select a different color for invalid data in the heat map 

(for example, for wells that were not measured and for 
which data was not collected), click Select, and in the dialog 
that opens, click a color and then click OK.

4. Click Close to close the Heat Map dialog and update the Heat 
Map display.

Table 4-3: Heat Map data calculation options 

Option Description

Manual If you select Manual, then in the Min and Max fields, type the 
lowest and highest values to include in the range of data. Values 
at or below the minimum (with rounding) are displayed with the 
“lowest” color and values at or above the maximum (with 
rounding) are displayed with the “highest” color. Values between 
the minimum and maximum are distributed along the scale and 
are displayed with corresponding colors.

Automatic If you select this option, then do one of the following for defining 
the range of data:
• To use the full range of data, select Data Min and Max.
• To have the MetaXpress Software distribute the data evenly 

below and above the mean value by a specific number of 
standard deviations, select Data range (# of SDs), and then 
type the number of standard deviations. This option 
calculates the range of data using the following formulas:
 Minimum Value = Mean - (# Standard Deviations X 

Standard Deviation)
 Maximum Value = Mean + (# Standard Deviations X 

Standard Deviation) 
For example, if the mean value of the range of data is 50, the 
standard deviation between values in the data is 2, and you 
type 5 as the # standard deviations, then the minimum value 
is 40 (50 - (5 X 2)) and the maximum value is 60 (50 + (5 X 2)). 
Values at or below the minimum (with rounding) are 
displayed with the “lowest” color and values at or above the 
maximum (with rounding) are displayed with the “highest” 
color. Values between the minimum and maximum are 
distributed along the scale and are displayed with 
corresponding colors.
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Viewing Image Overlay Information
Two options are available on the Image Overlay drop-down list on the 
Display tab on the Review Plate Data dialog for viewing image overlay 
information: Show well information and Show cell segmentation. 
If Show well information is selected, then the well, site (if multiple site 
data), time point (if time lapse data), and Z plane (if Z series data) are 
displayed as a text overlay on the upper left corner of the image. If the 
plate has been analyzed, then the measurement value based on the 
current measurement set and selected measurement for the displayed 
site is displayed as a text overlay on the lower right corner of the image. 
You select the color of the overlay from the Col drop-down list on the 
Display tab on the Review Plate Data dialog. You can toggle the overlay 
on or off from the source image with the Show/Hide overlay button on 
the side of the image window. If you use File > Save As to save the source 
image, then the overlay is also saved. 
If Show cell segmentation is selected when you are reviewing the data 
for a plate that has been analyzed and for which Save segmentation 
overlay to database was selected, then the overlay is displayed on top of 
the image.

You can toggle the overlay on or off from the source image with the 
Show/Hide overlay button on the side of the image window. If you use 
File > Save As to save the source image, then the overlay is also saved. 

Note: The overlay is saved to the database after automated analysis 
only if you select Save segmentation overlay to database when 
configuring the summary log for the application module, or Create 
Object Overlay when configuring the Measure tab for a custom 
module. The Save segmentation overlay to database option is not 
available for all application modules.
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Exporting the Settings File Used to Measure the Plate
After you load a Settings file for an analysis, you can modify the settings 
before you do the analysis. After you do the analysis, you have the option 
of exporting these settings. The values that are exported are the values 
that were used to measure the plate and acquire the plate data. When 
you export the Settings file, by default, the file name is used as-is and the 
file is exported to c:\assay, but you can change one or both of these 
values. If you export the settings for an application module, then the file 
extension depends upon the application module that was used to 
measure the plate. If you export the settings for a custom module, then 
the settings are exported to an .xml file. If you export the settings for a 
journal, then the settings are exported to a .zip file. 

1. In the Review Plate Data dialog, open the Measurements tab.

2. Next to the Analysis drop-down list, click Export Settings. 
3. In the Save Analysis Settings to file dialog, leave the default 

values of file name and location as-is, or modify one or both 
values as needed.

4. Click Save.

Note: To export a Settings file in its current state (the settings for the 
file at the time it was last saved), see Exporting a Settings File in its 
Current State on page 46.
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Exporting Selected Data
After you display analysis results, you can use the Log Data option that is 
available on the Measurement tab to export the results to an Excel 
spreadsheet in the same format in which the data is displayed in the 
Plate map. You can also export the results to a text file. If the data are 
cell-by-cell results, then you export this data using the Log Data option 
that is available on the Cellular Results table.

See:
• To export data to an Excel spreadsheet.
• To export data to a text (.log) file on page 63.
• To export cell-by-cell data to a text (.log) file on page 64.

To export data to an Excel spreadsheet
1. Do one of the following:
 To log a single measurement in plate format, select Well 

Arrangement for Data View.
 To log all data in column format, select Measurement vs 

Well for Data View.

Note: Alternatively, you can use the Export Measurements option on 
the Plate Data Utilities dialog to export selected data of one or more 
measurement sets to a text file. For more information, see Exporting 
Measurements through a Query on page 123.
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2. Click Configure Log, and in the Configure Log dialog, configure 
header information (Plate info, Column and row Labels, or 
both).

3. Click Open Log, and then in the Open Data Log dialog, select 
Microsoft Excel or other (DDE), and then click OK.

4. In the Export Log Data dialog, do the following:
 On the Application drop-down list, select Microsoft Excel.
 Type any of the following information: Sheet name, Starting 

Row, and Starting Column.
5. Click OK to close the Export Log Data dialog and link the 

measurement data to the Excel spreadsheet.
6. With the Excel spreadsheet open and connected to the 

MetaXpress Software, click Log Data to export the data that is 
currently displayed in the Plate map to the spreadsheet.

7. Optionally, if Data View is set to Well Arrangement, then to 
export another measurement set to the log file, select the 
appropriate measurement on the Measurements drop-down 
list, and then click Log Data.

8. Optionally, to stop exporting the data to the Excel spreadsheet at 
any time, click Log > Close Data Log (the default menu) or 
Measure > Log > Close Data Log (the simplified menu).

Note: Repeat Step 7 as many times as required to export 
different measurement set data for the same analysis. Every 
time that you click the Log Data button, the newly exported data 
is displayed below the previously exported data. As long as the 
connection between the Excel spreadsheet and the MetaXpress 
Software is maintained, existing data is not overwritten.
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To export data to a text (.log) file
Because Excel has a row limit, export data to a text file if you are 
exporting many data points, or if you are exporting cell-by-cell data. 

1. Click Configure Log, and in the Configure Log dialog, configure 
header information (Plate info, Column and row Labels, or 
both).

2. Click Open Log, and then in the Open Data Log dialog, select A 
text file.

3. In the Open Data Log file dialog, browse to the appropriate 
location for saving the log file, type a name for the log file, and 
then click Save to close the dialog and create and link the text 
file.

4. Click Log Data to export the data that is currently displayed in 
the Plate map to the text file.

5. Optionally, if Data View is set to Well Arrangement, then to 
export another measurement set to the log file, select the 
appropriate measurement on the Measurements drop-down 
list, and then click Log Data.

6. Optionally, to stop exporting the data to the text file, at any time, 
click Log > Close Data Log (the default menu) or Measure > Log > 
Close Data Log (the simplified menu).

Note: The .log file must remain closed while logging data. If you 
open the file through Windows Explorer, your data is not logged. 

Note: Repeat Step 5 as many times as required to export 
different measurement set data for the same analysis. Every 
time that you click the Log Data button, the newly exported data 
is displayed below the previously exported data. As long as the 
connection between the log file and the MetaXpress Software is 
maintained, existing data is not overwritten.
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To export cell-by-cell data to a text (.log) file
Cell-by-cell data is indicated by the word “Cell” preceding the 
measurement. 

1. Click Cellular Results to open the Cellular Results table.
2. In the Montage window, click the appropriate well.

3. Click Open Log.
4. Click Open Log, and then in the Open Data Log dialog, select A 

text file.
5. In the Open Data Log file dialog, browse to the appropriate 

location for saving the log file, type a name for the log file, and 
then click Save to close the dialog and create and link the text 
file.

6. Click Log Data to export the data that is currently displayed in 
the Plate map to the text file.

7. Optionally, if Data View is set to Well Arrangement, then to 
export another measurement set to the log file, select the 
appropriate measurement on the Measurements drop-down 
list, and then click Log Data.

8. Optionally, to stop exporting the data to the text file, at any time, 
click Log > Close Data Log (the default menu) or Measure > Log > 
Close Data Log (the simplified menu).

Note: Do not click in the Plate map as this changes the wells 
that are displayed in the Montage window.

Note: The .log file must remain closed while logging data. If you 
open the file through Windows Explorer, your data is not logged. 

Note: You can repeat Step 5 as many times as required to 
export different measurement set data for the same analysis. 
Every time that you click the Log Data button, the newly 
exported data is displayed below the previously exported data. 
As long as the connection between the log file and the 
MetaXpress Software is maintained, any newly exported data 
does not overwrite any existing data.
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Graphing Analysis Results
To configure a graph to display your data, use the following procedure:

1. In the Review Plate Data dialog, open the Graph tab.

2. On the Analysis drop-down list, select the analysis that contains 
the data that is to be graphed.

3. In the Graph view section, select the source location for the 
data.

4. On the Graph type drop-down list, select a graph type. The 
options available for each graph type vary depending on the 
selected Graph view.

5. On the Measurement drop-down list and, if applicable, the 
Measurement2 drop-down list, select the measurements that 
are to be graphed.

6. If you selected Histograms for the Graph type, then do the 
following. Otherwise, go to the next step.
 Select the number of bins to display in the resulting 

histogram in the Number of Bins field. 
 Select Auto Scale to automatically scale the bins based on 

the range of data from the selected measurement.
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7. Click Show Graph to open the graph based on the current 
settings. For example:

8. Optionally, do one or both of the following as needed:
 To configure the graph settings, double-click anywhere on 

the graph or click the Show graph menu arrow on the 
bottom left corner of the graph and select Graph Settings.

 To reset the display parameters for the current graph to the 
default view, click Set Display to Default. 

Note: If the data on the graph is not displayed properly, click 
and drag one of the corners of the graph window to resize it.

Note: Each combination of Graph view and Graph type has its 
own unique graph default.
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Application Modules
Application modules are the foundation of the MetaXpress® Software 
analysis workflow. These modules provide automated image analysis for 
biology-specific applications, interactive image segmentation, and data 
results, and options for data recording and management. Some examples 
of application modules include Count Nuclei, Transfluor, Micronuclei, 
and Cell Cycle.
This chapter includes the following topics:

• About Application Modules on page 67
• Configuring an Application Module on page 71
• Example: The Transfluor Application Module on page 85
• Cell-by-Cell Multiplexing with Application Modules on page 91

About Application Modules
An application module can be run in various ways:

• Automatically with the plate acquisition process. See the 
MetaXpress Help.

• Within the Review Plate Data dialog. See Configuring an 
Application Module on page 71.

• As a stand-alone analysis using an option on the Screening menu 
See the MetaXpress Help.

• As part of a custom module. See Chapter 6: Custom Modules on 
page 93 for an overview and the Custom Module Editor Help for 
details.

• Within a custom journal. See the MetaXpress Help.
• In a queue of automated analyses. See Chapter 9: Batch Analysis 

on page 115.
All modules share common conventions and settings. After you learn 
how to use one application module, you can easily use other application 
modules. For example, each module asks you to provide certain basic 
information about your images, such as the sizes, shapes, and intensities 
of the objects that are to be included in your analysis. Application 
modules require grayscale 16-bit fluorescent images, with one image for 
each wavelength that is to be analyzed. Some modules work with 
transmitted light images as well. 
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Molecular Devices offers numerous application modules. The application 
modules that are available with your version of the software depends on 
the terms of your license. For a list of currently available application 
modules, visit www.moleculardevices.com.
When choosing an application module, consider what your assay must 
measure. Your assay might encompass activation of a receptor, 
apoptosis, proliferation, and so on, but to obtain meaningful numerical 
data from screening, you must describe a phenotype that can be 
measured by the imaging system. Imaging systems do well at 
determining intensity, area, number of objects, or any combination of 
these measurements. To effectively translate your assay into useful 
measurements, evaluate the requirements of your assay in the simplest 
possible terms. For example, when counting cells, the brightest spots are 
generally of the greatest interest. Of these, only certain sizes and shapes 
might be of interest, as the other shapes might be dead cells or debris in 
the culture. Use the guidelines provided in Table 5-1 on page 68 to 
determine which application module is best suited for your assay.

Table 5-1: Application Module Guidelines 

Assay Type Description Recommended 
Application Modules

Protein Localization/
Translocation

Generally a measurement of co-
localization. The protein of interest is 
labeled or bound to by a labeled 
antibody and used with other probes 
specific to cell types, organelles, or 
cytoskeletal structures. The assay 
determines how much area or 
intensity of the protein-of-interest co-
localizes with another probe.

• Translocation
• Translocation-

Enhanced
• Multi Wavelength 

Translocation
• Nuclear 

Translocation HT
• Custom module

Cell Proliferation Generally a count of the cells or nuclei 
in an image. 

• Count Nuclei
• Multi Wavelength 

Cell Scoring
• Cell Proliferation HT

Cell Viability/Apoptosis Generally a count of objects having 
specific characteristics. The cells are 
rounded up (shape and area), the cells 
label or do not label with a specific 
probe (intensity and count), or specific 
proteins localize to a sub cellular 
compartment (intensity and count); for 
example, the mitochondria. 

• Live/Dead for a two- 
wavelength assay

• Cell Health for a 
three-color assay, 
such as DAPI, 
Annexin, or 
Propidium Iodide (PI)
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Receptor Internalization and 
other Punctuate Staining

Generally measured by a probe moving 
to coated pits or vesicles, such as in the 
Transfluor assay for GPCR activation. 
Count and measure labeled pits or 
vesicles, or other punctate staining.

• Granularity
• Transfluor
• Transfluor HT 
• Custom module

Angiogenesis Generally an area measurement. Either 
the length of tubules is measured or 
the creation of holes in a cell 
monolayer is measured.

• Angiogenesis 

Cell Physiology (Calcium/pH) Nearly always involves measurements 
of intensity. Generally a probe is used 
that changes its fluorescence intensity 
using one or two wavelengths under 
different physiological conditions. 
Two examples of this are Fluo-3 which 
increases its fluorescence with 
increasing free calcium concentration 
or Fura-2 in which the fluorescence 
with 340 nm excitation increases and 
380 nm excitation decreases with 
increasing free calcium concentration.

• Cell Scoring
• Multi Wavelength 

Cell Scoring 
• Custom module

Kinase Activity Assays Generally involve measuring the 
phosphorylated epitope of the kinase 
by measuring fluorescence intensity. 
Normalize this value to the number of 
cells expressing the kinase – a counting 
measurement. 

• Cell Scoring 
• Multi Wavelength 

Cell Scoring 

Neurite Outgrowth Assesses changes in shape and lengths. 
The outgrowth lengths, number of 
outgrowths, branching, and other 
parameters are counted.

• Neurite Outgrowth 
• Custom module

Table 5-1: Application Module Guidelines (cont’d)

Assay Type Description Recommended 
Application Modules
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Cell Cycle Generally involves the classification 
and counting of cells in specified stages 
of the cell cycle and analyzing the 
distribution of cells within these 
classes in response to compounds. 

• Cell Cycle for detailed 
classification using 
one to three 
wavelengths — from 
a single nuclear stain 
to combinations 
including optional 
mitosis-specific 
and/or apoptosis-
specific stains. 

• Mitotic Index for a 
simple two-
wavelength 
application with a 
nuclear stain and a 
mitosis-specific stain 
to measure the 
percent of cells that 
are mitotic.

• Monopole Detection 
for specific analysis 
of spindle formation 
and the disruption of 
centrosome 
separation.

Polynucleation and Genotoxicity Generally involves micronuclei, which 
are small nuclei produced during cell 
division by a lagging chromosome 
fragment or an entire chromosome.
Their induction is a highly quantitative 
measurement of chromosomal 
damage.

• Micronuclei for 
genotoxicity by 
detection of 
micronuclei in 
populations of mono-
, bi-, and multi-
nucleated cells. Can 
also be used for 
detection of yeast 
budding.

• Custom module

Table 5-1: Application Module Guidelines (cont’d)

Assay Type Description Recommended 
Application Modules
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Configuring an Application Module
Most application modules share similar configuration steps, such as 
selecting the source image to process, calibrating the source images, 
determining the width of an object, and providing the Intensity Above 
Local Background value. After you are familiar with these basic steps, 
you can use any of the various application modules. See:

• Calibrating the source images on page 71.
• Configuring the Settings file on page 72.
• Determining object widths on page 75.
• Measuring the area of an object on page 79.
• Calculating the intensity above background value on page 80.
• Testing and saving settings on page 81.

Calibrating the source images
For best results, calibrate the source images in all application modules in 
microns. Make sure that the X and Y calibration for an image match, and 
if more than one image is used as a source image, then the images must 
have identical distance calibrations. Images that were acquired using an 
ImageXpress® Micro System are calibrated in microns. Images that have 
been imported from another system or that have been processed might 
not be calibrated. 

Note: You can create your own custom module by combining various 
image processing and segmentation steps in the Custom Module Editor. 
These steps can include the application modules described in this guide. 
For detailed information about creating custom modules, see Custom 
Modules on page 93 for an overview and the Custom Module Editor 
Help for details.
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Configuring the Settings file
Every application module needs an associated Settings file that details 
the values that are to be used for the module-specific settings. You can 
select a pre-existing Settings file, or if the appropriate Settings file is not 
available, then either configure a Settings file for the module or import a 
Settings file. 
Every application module also needs at least one source image to 
process. Some modules need more than one source image. Examples of 
source image names in various application modules include:

• Count Nuclei: Source image
• Angiogenesis: Source image
• Translocation: Compartment image and Translocation Probe 

image
• Neurite Outgrowth: Neurite image and Nuclear Image

Two options are available for viewing a result image in an application 
module:

• You can display a separate result image.
• You can display an image overlay.

If you display a separate result image, the image is not saved, but 
separate result images are useful when creating journals.
Finally, an Algorithm option—Standard or Fast—is provided for some 
application modules. The Algorithm option determines how quickly the 
analysis is done. Both algorithms produce similar but not identical 
results.

Note: The appropriate type of source images varies depending 
on the application module used. For more information about 
source images, view the application help for the module you are 
using. The following procedure uses the Count Nuclei 
application module as an example, with a new Settings file being 
created for the module.
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To configure the Settings file 
1. Click Screening > Review Plate Data.

In the simplified menu structure, click Screening > Review Plate.
2. Open the plate and images that are to be analyzed as described 

in Chapter 3: Selecting and Analyzing Plates on page 13.
3. In the Review Plate Data dialog, click the Run Analysis tab.
4. From the Analysis drop-down list, select an application module.

5. Click Configure Settings.

6. Click Source image and select one of the images that you opened 
in Step 2. 

7. Do one of the following to view the results of the module:
 To display a separate result image, continue to Step 8.
 To display or create an image overlay, use the Show/Hide 

Overlay option on the side of the image window after the 
application module completes its analysis. See Viewing 
Image Overlay Information on page 59. Continue to Step 11.

Note: If the appropriate Settings file has previously been 
created, then you can click the Settings drop-down list and 
select it, and then continue as needed.

Note: Do not select images that start with HTS as these are 
thumbnail images.
5039429 C 73 



MetaXpress High Content Image Acquisition & Analysis Software Analysis Guide

MX_AnalysisGuide.book  Page 74  Wednesday, April 13, 2016  11:05 AM
8. Select Display result image.
9. Open the image selector for Display result image, and then 

select one of the following:
 Overwrite: (Recommended) Overwrites a selected image or 

creates a new image if one does not exist.
 Add to: Adds a plane to a stack.
 New: Creates a new image every time the assay is run.

10. Click the result image name (the default value is the [Source] 
image name), and then do one of the following in the Specify 
Image Name dialog:
 Select the appropriate image name from list of available 

images.

 Select Specified, and then modify the image name as 
appropriate. 

11. If the application module provides an Algorithm option, select 
either Standard or Fast, and if you select Fast, then in the 
Intensity above local background field, type approximately half 
of the value that you calculate in Calculating the intensity above 
background value on page 80.

Note: If Display result image is selected, but an image is not 
selected (None is displayed), then you receive an error if you try 
to run the application module.

Note: Do not select images that start with HTS as these are 
thumbnail images.

Note: If you are running the module within a journal, then 
Molecular Devices recommends that you select Specified and 
modify the image name accordingly.

Note: The Standard algorithm is the algorithm that was used in 
version 3.1 and earlier of the MetaXpress Software.
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12. Continue as needed to specify the values that the application 
module requires, for example, determining object widths, before 
processing the images.

Determining object widths
Most application modules require that you specify object size 
measurements before processing the images. You can measure an object 
using one of the following:

• Region tools Line tool. See To measure the width of an object 
with the Single Line Regions tool on page 75.

• Caliper tool. See To measure the width of an object using the 
Calipers tool on page 77.

To measure the width of an object with the Single Line Regions 
tool

1. If the Region toolbar is not open, click Regions > Region Tools.
In the simplified menu structure, click Measure > Regions > 
Region Tools.

2. Click the Single Line tool.

3. Click one of the edges of the smallest object that is to be 
included in your analysis. 
A tooltip opens that shows the current X and Y values of the 
pointer. A placeholder is displayed for the Length.

4. Move the cursor to the opposite edge of the object and note the 
Length value.
In the following example, the value is 10 pixels (or 12.87 μm). 
This value represents the object width in pixels. If the image is 
calibrated, then the length is in pixels and calibrated units.
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5. In the Configure Settings dialog, in the Approximate min width 
field, type or select the value in microns. 

6. To remove the region lines, select Clear Regions on the Regions 
menu or right-click on the region and click Delete Region.

7. Click one of the edges of the largest object that is to be included 
in your analysis. 
A tooltip opens that shows the current X and Y values of the 
pointer. A placeholder is displayed for the Length.

8. Move the cursor to the opposite edge of the object and note the 
Length value.

9. In the Configure Settings dialog, in the Approximate max width 
field, type or select the value in microns.

10. To remove the region lines, select Clear Regions on the Regions 
menu or right-click on the region and click Delete Region.

11. Continue as needed to specify the values that the application 
module requires, for example, determining the Intensity above 
local background, or if you are done configuring the module, 
then continue to Testing and saving settings on page 81.
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To measure the width of an object using the Calipers tool

1. Click Measure > Calipers. 
In the simplified menu structure, click Measure > Distances > 
Calipers.

2. In the Calipers dialog, from the Image selector, select the image 
to measure. 
The calipers appear on the selected image, as shown in the 
following figure. 

3. To move the calipers to the smallest object that is to be included 
in your analysis, click the cross-bar so that it appears as a blinking 
line, and then use the cross-bar to drag the calipers to the object.

Note: The Calipers feature is a drop-in option and might need to be 
loaded into the MetaXpress Software. If the option is not present on the 
Measure menu (default menu), or on the Measure > Distance menu 
(simplified menu), contact your System Administrator or Technical 
Support to have this drop-in loaded.
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4. To measure the width of the object, do the following:
 Click one of the caliper edge lines so that it appears as a 

blinking line, and then drag the line to the edge of the 
object. The other caliper line remains anchored.

 Click the other caliper edge lines so that it appears as a 
blinking line, and then drag the line to the opposite edge of 
the object.

The size of the line is displayed in the image and in the Calipers 
dialog.

5. In the Configure Settings dialog, in the Approximate min width 
field, type or select the value in microns. 

6. Repeat Step 3 through Step 5 for the largest object that is to be 
included in your analysis and type or select its width in the 
Approximate max width field.

7. Click Close to close the Calipers dialog.
8. Continue as needed to specify the values that the application 

module requires, for example, determining the Intensity above 
local background, or if you are done configuring the module, 
then continue to Testing and saving settings on page 81.
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Measuring the area of an object
1. If the Region toolbar is not open, click Regions > Region Tools.

In the simplified menu structure, click Measure > Regions > 
Region Tools.

2. Select the Trace Region tool. 

3. Click and hold the left mouse button to draw a region of interest 
around a typical compartment. Double-click the left mouse 
button to close the region. The region line blinks to indicate that 
the region is selected.

4. Click Measure > Show Region Statistics. 
In the simplified menu structure, click Measure > Distances > 
Show Region Statistics.

5. For Measure, select Active Region. 
The area of the object is displayed in the Area field of the 
Measurements table (the left table) on the dialog. This value 
represents the object area in pixels. If the image is calibrated, 
then the area is in pixels and calibrated units.

6. Click Close to close the Show Regions Statistics dialog.
7. Continue as needed to specify the values that the application 

module requires, for example, determining the Intensity above 
local background, or if you are done configuring the module, 
then continue to Testing and saving settings on page 81.
5039429 C 79 



MetaXpress High Content Image Acquisition & Analysis Software Analysis Guide

MX_AnalysisGuide.book  Page 80  Wednesday, April 13, 2016  11:05 AM
Calculating the intensity above background value
The Intensity above local background field is common for all application 
modules. It specifies a value for the intensity threshold of the objects of 
interest compared to the neighboring background gray-level values. This 
setting controls the sensitivity of the object detection and segmentation.
The value that you type in the Intensity above local background field 
depends on whether the application module provides the Standard and 
Fast algorithms. If the application module does not provide either 
algorithm or if you select the Standard algorithm, then type a value that 
is slightly lower than the calculated value. If you select the Fast 
algorithm, then in the Intensity above local background field, type a 
value that is approximately half of the calculated value.

1. If the Region toolbar is not open, click Regions > Region Tools.
In the simplified menu structure, click Measure > Regions > 
Region Tools.

2. Select the Arrow tool.

3. Move the arrow cursor over the dimmest part of the dimmest 
object in the image. 
As you move the cursor, the X,Y coordinates and the gray-level 
value of the pixel under the cursor are indicated at the bottom of 
the MetaXpress Software desktop. The X,Y coordinates are in 
parentheses and the gray-level value is to the right of the arrow. 
For example:

4. Note the gray-level value of the object. 
5. Move the cursor just outside the object to the background of the 

image and note the gray-level value of the background.
6. Calculate the difference between the gray-level value of the 

object and the background. For example, using a gray-level value 
for a cell of 366 and a background value of 304, the calculation 
is: 366 – 304 = 62. Based on the guidelines, then, in this example, 
you would specify a value of approximately 60 for the Intensity 
above local background. 
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7. Continue as needed to specify the values that the application 
module requires, or if you are done configuring the module, then 
continue to Testing and saving settings on page 81.

Testing and saving settings
After the module is configured, test the settings, make adjustments if 
needed, and then save the settings. When testing the module settings, 
the Preview option shows the segmented image using just the selected 
wavelength, and you can use this option or the Test Run option. The Test 
Run option uses all wavelengths, and this must be the option that you 
use for the final test.

1. In the application module dialog that you just configured, click 
Test Run.
The application module runs and an overlay image appears on 
the original image. If Display result image is selected, then a 
result image opens as well. A Cellular Results table that contains 
individual object data also opens. The following figure shows a 
sample source image with an overlay (left) and a result image 
with the cells individually colored (right).

Tip: You can also consider Linescan as an alternate method for 
intensity measurements. Draw a line across a dim object and its 
local background, and then use the Linescan tool that is 
available from the Measure > Intensities menu (simplified 
menu) or the Measure menu (default menu) to see more exact 
intensity values. See the MetaXpress Software application help 
for more information about this tool.

Note: Configure and save settings before you run an application 
module for the first time. After the settings are saved, they can be 
loaded as needed without further configuration. 
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2. Click a cell in the image to highlight the data in the Cellular 
Results table for the cell. Use Ctrl+Click or Shift+Click to select 
more than one row of data. 

3. Compare the result image with the source image to determine if 
all the objects of interest are being detected. 
 If all objects of interest are being detected, then continue to 

Step 4.
 If all objects of interest are not being detected, then lower 

the value in the Intensity above background field and run 
the module again before modifying the Approximate max 
width and Approximate min width fields, or other required 
values. After you are satisfied that all objects of interest are 
being detected, continue to Step 4.

4. To specify the site by site data that is to be recorded for the 
application module, click Configure Summary Log, and in the 
Configure Log dialog, select or clear the appropriate settings. 

Note: If the table does not open when you run an application 
module, then from the Window menu, you can select Show 
Cellular Results
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5. Click OK close the dialog and apply the settings.

Note: The image overlay is saved to the database with the 
image after automated analysis only if you select the Save 
Segmentation Overlay to Database option when configuring the 
summary log for the application module. This option is not 
available for the Cell Proliferation HT, Nuclear Translocation HT, 
and Transfluor HT application modules. 

Note: Segmentation overlay takes a significant amount of space 
in the database and Molecular Devices does not recommend 
saving it for large images.

Note: For more information on the data that can be logged, see 
the application help Dialog options topic for the application 
module you are using.
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6. If applicable, to configure the cell by cell data that is to be 
recorded for the application module, click Configure Data Log, 
and in the Configure Log dialog, select or clear the appropriate 
settings.

7. Click OK close the dialog and apply the settings.
8. Click Save Settings.
9. In the Save Settings dialog, type a name and description for the 

application module settings. 

10. Click OK to close the dialog and save the application module 
settings to the database. 

11. Click Close.
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Example: The Transfluor Application Module
The procedures that were described in Configuring an Application 
Module on page 71 work with any application module. This section 
provides an example of procedures that are specific to a module, the 
Transfluor application module. See:

• To select the wavelength image on page 85.
• To determine the object widths on page 86.
• To determine Intensity above local background on page 87.
• To test the application module settings on page 88.
• To specify how data should be recorded on page 89.
• To run the application module on page 90.

To select the wavelength image
1. Use the Review Plate Data dialog to select a plate as described in 

Chapter 3: Selecting and Analyzing Plates on page 13.
2. Click one of the wells to display an image.

3. In the Review Plate Data dialog, click the Run Analysis tab.
4. From the Analysis drop-down list, select <Transfluor>.
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5. Click Configure Settings.
6. In the Configure Settings for Transfluor dialog, click the Pits and 

Vesicle image selector, and then select the wavelength image 
that represents the pits and vesicles.

7. Click the pits and vesicles image, and then increase the zoom by 
clicking the magnifying glass icon on the image window or by 
pressing Page Up on the keyboard.

8. Continue to To determine the object widths.

To determine the object widths
To determine the objects, you can use the Single Line tool on the Region 
toolbar to measure a granule width according to the following steps:

1. If the Region toolbar is not open, click Regions > Region Tools.
In the simplified menu structure, click Measure > Regions > 
Region Tools.

2. From the Region Tools toolbar, select the Single Line tool.

.

3. In the image window, click one of the edges of the smallest pit 
that is to be included in your analysis. 
A tooltip opens that shows the current X and Y values of the 
pointer. A placeholder is displayed for the Length.
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4. Move the cursor to the opposite edge of the pit and note the 
Length value.
The following figure shows that, in this example, the length is 3 
pixels or 1.41μm. This value represents the object width in pixels. 
If the image is calibrated, then the length is in pixels and 
calibrated units.

5. In the Configure Settings dialog, in the PIts section, in the 
Approximate min width field, type or select the value in 
microns. 

6. To remove the region lines, select Clear Regions on the Regions 
menu or right-click on the region and click Delete Region.

7. Click one of the edges of the largest pit that is to be included in 
your analysis. 
A tooltip opens that shows the current X and Y values of the 
pointer. A placeholder is displayed for the Length.

8. Move the cursor to the opposite edge of the pit and note the 
Length value.

9. In the Configure Settings dialog, in the Pits section, in the 
Approximate max width field, type or select the value in 
microns.

10. To remove the region lines, select Clear Regions on the Regions 
menu or right-click on the region and click Delete Region.

11. Continue to To determine Intensity above local background.

To determine Intensity above local background
1. On the Regions toolbar, click the Locator tool.

2. Position the cursor over the dimmest pit and read the gray-level 
value. 
The gray-level value is the number that is displayed at the middle 
of the bottom of the screen after the right arrow. For example, in 
the following figure, the value is 162.
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3. Move the cursor to just outside the pit to measure the 
background. 

4. Calculate the difference between the gray-level value of the pit 
and the background.

5. In the Pits section, Intensity above local background field, type 
or select a value that is slightly lower than the calculated value. 
For example, if you calculated an Intensity above local 
background value of 1000, then a value of 800 is appropriate. 

6. If applicable, repeat for vesicles. Otherwise, clear the Vesicles 
check box.

7. Continue to To test the application module settings.

To test the application module settings
When you test the module, you first confirm that pits are being detected 
correctly. If you are using a nuclear stain, you then confirm that nuclei 
are being detected correctly.

1. Clear the Nuclear stain check box. 
2. Click Test Run to test your settings to display the pits and vesicles 

segmentation as an overlay on the image. 
3. On the Image window toolbar, use the Show/Hide Overlay tool 

to toggle the results on or off to make sure all the pits are 
detected. 

Note: Vesicles are much larger and brighter than pits.
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4. Do one or both of the following as needed:
 If all the pits are not detected, then lower the Intensity 

above local background value and check the results again 
with the Show/Hide Overlay tool. 

 If lowering the intensity value does not produce the needed 
results, then modify the other parameters or continue to 
modify the intensity value with the other parameters and 
check with the Show/HIde Overlay tool until the needed 
results are obtained.

5. Select a negative control image, and then click Test Run to make 
sure that your settings are correct. (Objects that are not pits are 
not being detected as such.)

6. If you are using a nuclear stain, then select Nuclear stain and 
repeat Step 2 through Step 5 for the nuclei in the image. 

7. Click Test Run to open the Cellular Results table.
8. Use the Cellular Results table to interactively view individual 

cellular results and confirm that the results are as expected. 
Otherwise, make adjustments as needed, and continue testing 
until the appropriate results are obtained.
 Clicking a cell in the image highlights the data for the 

selected cell in the table. 
 Clicking a row in the table highlights the corresponding cell 

in the image. 
 To select and view more than a single line of data, press 

Ctrl+Click.
 To select non-contiguous cells or lines of data can, press 

Shift+Click.
9. Continue to To specify how data should be recorded.

To specify how data should be recorded
1. Click Configure Summary Log. 
2. To specify the site by site data that is to be recorded for the 

application module, click Configure Summary Log, and in the 
Configure Log dialog, select or clear the appropriate settings.

3. Click OK close the dialog and apply the settings.
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4. To save the image overlay to the database with the image after 
automated analysis, select the Save Segmentation Overlay to 
Database.

5. If applicable, to configure the cell by cell data that is to be 
recorded for the application module, click Configure Data Log, 
and in the Configure Log dialog, select or clear the appropriate 
settings.

6. Click OK close the dialog and apply the settings.
7. Click Save Settings.
8. In the Save Settings dialog, type a name and description for the 

application module settings. 
9. Click OK to close the dialog and save the application module 

settings to the database. 
10. Click Close.
11. Continue to To run the application module.

To run the application module
1. In the Review Plate Data dialog, on the Run Analysis tab, on the 

Settings drop-down list, select the saved Transfluor settings file 
that you created. 

2. Run the analysis. See Running an Analysis on page 34.
3. After the analysis is run, view the results in the Cellular Results 

table, on the Measurements tab, or on the Graph tab. See 
Chapter 4: Viewing Analysis Results on page 49 for more 
information.
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Cell-by-Cell Multiplexing with Application Modules
One of the advantages of high content screening is the ability to 
multiplex assays by running multiple analyses on the same samples. For 
example, you could run a Cell Scoring assay to measure transfection 
efficiency and a Transfluor assay to measure receptor internalization on 
the same sample. In the MetaXpress Software, these analyses can be 
multiplexed on cell-by-cell data.
Compatible modules for cell-by-cell multiplexing include Cell Cycle, Cell 
Health, Cell Scoring, Count Nuclei, Granularity, Mitotic Index, 
Monopole Detection, Multi Wavelength Cell Scoring, Multi Wavelength 
Translocation, and Transfluor assays.

1. Configure each application module. Make sure that the same 
nuclear detection settings and algorithm are selected for each 
module.

2. Run each application module separately for selected wells or for 
all wells.

3. Review the data in either the AcuityXpress Software or in 
another application such as Microsoft Excel.

For more information about techniques for multiplexing assays, contact 
Technical Support.

Note: You can also multiplex assays by creating a custom module that 
includes multiple application modules. For detailed information about 
creating custom modules, see the help provided in the Custom Module 
Editor. 
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Custom Modules
Not all samples can be meaningfully or accurately assessed with just one 
standard application module. Often, you must combine an array of 
preprocessing and segmentation methods to effectively analyze sets of 
images. Applications such as protein subcellular patterns or fluorescence 
co-localization of objects are often best done with a sequence of steps. 
For example, you might want to remove noise, invert an image, increase 
intensity levels, extract objects of interest, shrink or remove objects, and 
then measure the objects in images acquired with different channels. A 
custom module makes this type of complex, repetitive task simple to do. 
Moreover, depending on your research goals, you might want to use the 
same sequence of steps to analyze numerous datasets, or share a custom 
module with other researchers for use in their datasets.
The MetaXpress Custom Module Editor is an optional, flexible, 
interactive environment in which you can create a template for an image 
analysis that can be distributed and re-used. You select from galleries of 
processing options, morphology filters, and segmentation methods to 
construct a sequence of analysis steps that are displayed in Step Cards in 
the Create Custom Module (left) pane of the workspace. When you test 
(apply) a step, a result image is automatically displayed in the Image Grid 
and the Filmstrip pane in the workspace. 
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The general sequence of tasks for creating a custom module are:
94 5039429 C 



Custom Modules

MX_AnalysisGuide.book  Page 95  Wednesday, April 13, 2016  11:05 AM
• Select the plate: In the Review Plate Data dialog, select the plate 
that to use as the basis for the custom module, and then click 
Create Custom Module to open the Custom Module Editor. 
Alternatively, to modify an existing custom module, on the 
Analysis drop-down list, select the appropriate custom module, 
and then click Configure Custom Module.

In the Custom Module Editor:
• Pre-process the image: Generally, the first steps in configuring a 

custom module are pre-processing steps to improve the image 
quality so that objects of interest can then be clearly defined 
with segmentation options. The Modify Image group offers 
many options that enhance features, increase the level of detail, 
and remove unwanted image artifacts. These options can, 
among many other things, shrink and grow dark and light 
objects, smooth light and dark objects simultaneously, detect 
bright or dark features of a specific spatial size or shape, increase 
local contrast, detect edges, fill holes, and invert an image.

• Find the objects: When the image quality is optimal, then in the 
second series of steps, you use the segmentation options in the 
Find Objects and Application Module Objects groups to define 
the objects of interest. The result image from these steps is a 
black and white image called a mask image. 

• Refine the objects: If needed, you can add a third series of steps 
from the Modify Objects group to further define the location 
and boundary of each object in the mask image. For example, 
you can remove border objects, invert objects, and keep or 
remove marked objects. Logical operations are available for 
combining or separating images. Optionally, you can filter the 
objects based on their properties, such as size or intensity.

Note: If you have Z Series data loaded in the Review Plate Data 
dialog, and your organization has purchased and installed the 
optional 3D Custom Module (also referred to as a Volume 
Module), then when you click Create Custom Module or 
Configure Custom Module, the 3D Custom Module opens 
automatically with your data loaded.
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• Measure the objects: After you are satisfied that the mask steps 
that you have specified define the locations and boundaries of 
objects in the image accurately and reproducibly, then you 
specify the Measure Mask step. The Measure Mask step, which 
is the final analysis step, defines the properties of the objects to 
be measured, for example, total area, area, hole area, average 
intensity, and so on. Optionally, you can then add one or more 
feature groups that specify the binary mask images to use to 
measure the features, which are the objects that are contained 
within the objects that are identified in the main mask. 

• Test the custom module: Each time you run a custom module in 
the Custom Module Editor, the measurement results are 
displayed in a Measurement data table in the Data Table pane. 
You can select data in the Measurement data table to update the 
image view and you can also display the measurement results in 
a graph. 

• Save and export the custom module: After you have defined all 
the required steps for the custom module, you then save the 
module. When you save a custom module, it is automatically 
added to the list of available modules on the Analysis drop-down 
list on the Review Plate Data dialog. To share the module with 
other users who are using different MetaXpress Software 
databases, export the module. When you export a custom 
module, it is saved as an XML file. After you save or export a 
custom module, you can import it into the Custom Module 
Editor to modify it or you can modify it directly from the Review 
Plate Data dialog. 

Tip: You can also use the Export Custom Module function as a method 
of backing up a custom module. 

Note: For a detailed explanation about using the Custom Module 
Editor to create and modify your needed custom modules, see the help 
for the Custom Module Editor.
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Journals
Journals are powerful macros for the MetaXpress Software. Journals 
provide customizations beyond that of custom modules, and they can 
extend the capabilities of the MetaXpress Software for both image 
acquisition and image analysis. Some examples of analysis journal 
routines include the following:

• Load saved regions, and then measure the intensity within the 
regions.

• Score cells based on calculations using measurements from 
multiple analysis modules.

• Map objects in images to a grid.
• Stitch multiple sites together, and then do neurite outgrowth 

analysis.
• Analyze up to a specific number of cells per well, and then skip 

the remaining sites in the well.
All journals can be recorded, edited, saved, and run. After journals and 
any associated files are uploaded to the MDCStore database from one 
MetaXpress computer, they can be run on any MetaXpress computer 
that is connected to the same database. Selecting a journal analysis 
downloads a local copy of these files to the computer that is running the 
analysis. 
This chapter includes the following topics:

• Considerations for Designing an Analysis Journal on page 98
• Adding an Analysis Journal to the MetaXpress Software Database 

on page 101
• Adding a Setup Journal to the MetaXpress Software Database on 

page 104
• Adding a Post Journal to the MetaXpress Software Database on 

page 105

Note: For more information on creating journals, visit the Molecular 
Device knowledge base at http://www.moleculardevices.com/support. 
Example journals can be downloaded from the 
MetaMorph/MetaXpress User Forum at 
http://metamorph.moleculardevices.com/forum/.
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Considerations for Designing an Analysis Journal
Before you design an analysis journal, it is important to understand how 
the journal and the available images are looped as the journal runs 
across the plate. You must consider the following:

• Wavelengths
• Wells
• Sites
• Time lapse assays
• Database logging

Wavelengths
The wavelengths that are selected on the Review Plate Data dialog or 
the Run Analysis on Plates dialog (Plate Data Utilities > Run Analysis > 
Select Plate for Analysis) determine the images that are available for the 
analysis journal. All the wavelengths that are selected for the plate are 
opened for each site as the journal analysis runs. The images are named 
the same as the selected wavelengths. For example, as shown in the 
following figure, the images are named DAPI and FITC. The Transmitted 
Light 25 image is not selected, and therefore, it is not available as the 
analysis journal runs.

Wells
The analysis starts with the upper-left well (A01), moving across to the 
right in the first row (A12 for a 96-well plate), and then down to the start 
of the next row (B01). Likewise, it moves across to the right and down, 
finishing with the last row of the plate from left to right. All sites within 
each well are run before the analysis moves to the next well.
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Sites
Within each well, the analysis starts with site 1, then runs on site 2, and 
so on, until it has completed the final site. It then moves to the next well. 
All sites within each well are run before the analysis moves to the next 
well. For time-lapse assays and Z-series assays, there are more analysis-
order considerations that depend on the time-lapse or Z-series option 
that is selected.

Time lapse assay

Table 7-1: Analysis order for a time lapse assay

Time Lapse Option How the journal loops

• All timepoints
• Time point range

Within each site, the analysis runs on the first 
selected time point, and then on the 
subsequent time points one at a time, until the 
final time point is completed. The analysis then 
moves to the next site.

• Stack of all time points For each site, all available time points are 
loaded into a stack for each selected 
wavelength. The journal can then do stack 
arithmetic or loop through the planes as 
appropriate for the specific analysis.

• Selected time point For each site, a single time point is run.

Table 7-2: Example of analysis order with a multi-site plate run using the 
All time points option 

Well Site Analysis Order

A01 Site 1 Time point 1

Time point 2

Site 2 Time point 1

Time point 2

A02 Site 1 Time point 1
Time point 2

Site 2 Time point 1

Time point 2
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Z series assay

Database logging
Any steps in a journal that log data (for example, Show Region Statistics 
or an application module), generally log data to the database. To avoid 
unwanted data appearing for intermediate steps and stop the database 
logging, use the Stop/Resume Logging to Database journal function. The 
following figure shows an example journal that uses the Stop/Resume 
Logging to Database journal function. 

You must also consider how to manage database logging based on the 
type of data that the journal is measuring: cell data, time lapse data, or Z 
series data.

Table 7-3: Analysis order for a Z series assay

Time Lapse Option How the journal loops

• All Z steps
• Z step range

Within each site, the analysis runs on the first 
selected Z step, and then on the subsequent Z 
steps one at a time, until the final Z step is 
completed. The analysis then moves to the next 
site.

• Stack of all Z steps For each site, all available Z steps are loaded 
into a stack for each selected wavelength. The 
journal can then do stack arithmetic or loop 
through the planes as appropriate for the 
specific analysis.

• Selected Z step
• 2 D projection image

For each site, only the indicated single image for 
each wavelength is run.
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Cell data
If the analysis journal is measuring cell data by looping through objects 
or regions, then to log each data point as a separate cell, use the Set Cell 
Number for Database Logging journal function.

Time lapse data
If the analysis journal is running on a time lapse assay using the Stack of 
all time points option, then to log data specifically for each time point, 
use the Set Time and Z Step for Database Logging journal function.

Z series data
If the analysis journal is running on a Z series assay using the Stack of all 
Z steps option, then to log data specifically for each Z step, use the Set 
Time and Z Step for Database Logging journal function.

Adding an Analysis Journal to the MetaXpress Software Database
Before you can add an analysis journal to the MetaXpress Software 
database, you must verify that any computer that is to run the journal 
has the MetaXpress Software installed on it, that the folders c:\analysis 
and c:\assay are present, and that the Windows user has full control 
(Read, Write, and Modify) for these folders. When you add an analysis 
journal to the MetaXpress Software database, you can create new 
analysis settings, or you can overwrite existing analysis settings. You can 
add multiple settings for any analysis journal. These might include 
different analysis parameters such as threshold settings, region files, or 
IMA state files. After you add an analysis journal to the MetaXpress 
Software database, the journal is available for selection on the Analysis 
drop-down list on the Run Analysis tab of the Review Plate Data dialog.

CAUTION! If you modify an existing analysis journal by editing the 
journal file or other associated files inside the c:\assay\ folder on your 
MetaXpress computer, then you must add the analysis to the 
MetaXpress Software database to save the changes. Otherwise, running 
the analysis journal with the existing settings overwrites your local 
changes.
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1. On the MetaXpress Software computer, in the c:\assay folder, 
create a subfolder that is named exactly the same as the analysis 
journal that is being added to the database: c:\assay\Journal 
Name.

2. Save the journal (*.jnl) and if applicable, any associated files to 
this subfolder.

3. In the MetaXpress Software, on the main menu, click Screening > 
Add Analysis to Database.

4. In the Add Analysis to Database dialog, click Select Directory, 
and then browse to and select the directory that contains the 
analysis journal.
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5. Continue to one of the following:
 To create new analysis settings on page 103.

 To overwrite existing analysis settings on page 103.

To create new analysis settings
1. Under Settings, select Add new.
2. In the Name field, type the name for the new analysis settings.

3. Optionally, in the Analysis Description field, type a description 
for the new analysis settings.

4. Click Add.

5. In the Add Analysis message dialog, click OK.

To overwrite existing analysis settings
1. Under Settings, select Overwrite existing.
2. On the Name drop-down list, select the name for the existing 

analysis settings.
3. Optionally, in the Analysis Description field, modify the existing 

description for the analysis settings.

Note: If you are adding a new analysis journal, then you must 
add new analysis settings.

Note: Remember, the name for the new analysis settings and the name 
of the subfolder that contains the settings must be identical.
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4. Click Overwrite.

5. In the Add Analysis message dialog, click OK.

Adding a Setup Journal to the MetaXpress Software Database
A setup journal is always optional and it is run before the main analysis 
journal. A setup journal is used to do actions that are generally run 
before the main analysis such as assigning variables, opening a log, or 
loading an IMA state file. To create and run a setup journal, do the 
following:

1. Create the setup journal that contains the appropriate steps. 
When you name the setup journal, name it identically to the 
main analysis journal and add the suffix “_setup.” See Adding an 
Analysis Journal to the MetaXpress Software Database on 
page 101.

2. Save the setup journal in the same c:\assay subdirectory as the 
main analysis journal.

3. To run the setup journal:
 If you are using the Review Plate Data dialog to run the 

analysis, then after you select the main analysis journal on 
the Analysis drop-down list on the Run Analysis tab, a Run 
Setup for Analysis option is displayed. Click this option to 
run the setup journal. If no setup journal exists, then the 
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message “No setup journal exists for this analysis” is 
displayed.

 If you are running the analysis through the Plate Data 
Utilities > Run Analysis > Run now on this computer option, 
then the setup journal is automatically run at the start of 
every plate that is being analyzed. This is important to note if 
the setup journal includes any interactive steps, as the 
analysis pauses while it waits for user input.

 If you are running the analysis in Auto Run mode, then the 
setup journal does not run.

Adding a Post Journal to the MetaXpress Software Database
A post journal is always optional and it is run after the main analysis 
journal. A post journal is used to do actions that are generally run after 
the main analysis such as resetting variables or log files, or calculating 
plate-based statistics. To create and run a post journal, do the following:

1. Create the post journal that contains the appropriate steps. 
When you name the post journal, name it identically to the main 
analysis journal and add the suffix “_post.” See Adding an 
Analysis Journal to the MetaXpress Software Database on 
page 101.

2. Save the post journal in the same c:\assay subdirectory as the 
main analysis journal.
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3. To run a post journal:
 If you are using the Review Plate Data dialog to run the 

analysis, then the post journal does not run automatically 
after the main analysis is complete. Instead, run the post 
journal manually by clicking Run > Run Journal (or Control > 
Journal > Run Journal in the Simplified menu), and then 
selecting the appropriate post journal.

 If you are running the analysis through the Plate Data 
Utilities > Run Analysis > Run now on this computer option, 
then the post journal is automatically run at the end of every 
plate that is being analyzed.

 If you are running the analysis in Auto Run mode, then the 
post journal does not run.

Table 7-4 summarizes the behavior of the optional setup and post 
journals for the different methods of running a journal analysis.

Table 7-4: Journal behavior when using different methods to run journals

Setup Journal Main Analysis Journal Post Journal

Review Plate Data 
dialog

Click Run Setup for 
Analysis to run.

Runs on all wells, or 
selected wells as 
defined by the user.

Does not run 
automatically. Run the 
journal manually 
instead.

Run Analysis > Run now 
on this computer

Runs automatically at 
the start of each plate.

Runs on all wells. Runs automatically at 
the end of each plate.

Auto Run mode Does not run. Runs on all wells. Does not run.
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Automating and Monitoring an Analysis
After you have tested the analysis settings for a specific application 
module or a custom set of journals and are confident in the results, you 
can use the automated analysis features in the MetaXpress® Software to 
increase your data analysis throughput. 
Automated analyses can be started at one or more analysis workstations 
concurrently with acquisition. You can also automatically run analyses on 
an acquisition system after the acquisition is complete. 

An analysis can run on systems running either the full or offline (analysis 
only) version of the MetaXpress Software. The systems must be 
connected to your database and logged in with privileges to view plates 
and write data. As image data is retrieved from the MDCStore™ database 
storage location that is specified during acquisition, the systems need 
privileges to access this storage location as well. After the images are 
analyzed, the analysis results are stored back in the MDCStore database. 
Using automated analysis provides several benefits, including the ability 
to dedicate designated workstations for running specific analysis 
application modules. Also, by dedicating a workstation for doing 
acquisitions only, the overhead for the acquisition system is significantly 
reduced.

Note: Automated analysis using application modules and custom 
modules can also be run with the MetaXpress® PowerCore™ Software 
after the acquisition has been completed. Analysis of custom journals 
must be done using the MetaXpress Software. For more information 
about the MetaXpress PowerCore Software, see the product 
documentation available in the Molecular Devices knowledge base at 
http://www.moleculardevices.com/support.
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Setting up and running an automated analysis involves two main steps:
1. Before starting an acquisition, configure the analysis settings on 

the acquisition workstation using the options on the Post 
Acquisition tab on the Plate Acquisition Setup dialog. 

2. Initiate automated analysis using the Auto Run Mode dialog. 

After the Auto Run Mode has started, you can use the Auto Run Plate 
Statuses dialog to monitor and control the progress of each analysis 
running for each plate being analyzed. 
This chapter includes the following topics:

• Setting Up an Automated Analysis on page 108
• Initiating an Automated Analysis on page 110
• Monitoring the Status of Automated Analyses on page 112

Setting Up an Automated Analysis
To choose a specific analysis to run on a data set after the acquisition is 
complete, select Analyze Images After Acquisition on the Acquisition 
tab on the Plate Acquisition Setup dialog, and then specify the analysis 
options on the Analysis tab. If the system is set to Auto Run mode, then 
the data set is added to the Auto Run queue for analysis. You can select 
from a list of saved settings for any application module, custom module, 
or journal assay that is saved to the database. 

Note: If the analysis that is configured on an acquisition workstation 
calls for an application module to run, the application module drop-in 
must be installed on the computer that is running in Auto Run Mode. 
The application module drop-in must be enabled on the acquisition 
workstation before you can select it here.

Note: If you do not want to automatically run post-acquisition analysis, 
ensure that Analyze Images After Acquisition is not selected on the 
Acquisition tab.

Note: The list of available assays and settings is a subset of the list that 
is on the Run Analysis tab of the Review Plate Data dialog. Analyses 
that do not have settings defined are not shown.
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To select an analysis to run automatically after acquisition:
1. In the Plate Acquisition Setup dialog, on the Acquisition tab, 

select Analyze Images After Acquisition, and then open the 
Analysis tab.

2. On the Analysis drop-down list, select the assay (application 
module, custom module, or journal assay) to run after 
acquisition.

3. On the Setting drop-down list, select a settings file. 
A description of the settings file appears below the Settings field.

4. Continue to Initiating an Automated Analysis on page 110.

Note: Only analyses that have defined settings are listed.

Note: You can configure and save settings in the Review Plate 
Data dialog.
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Initiating an Automated Analysis
Using the Auto Run Mode, a networked system can run an analysis on 
plates automatically after they are acquired. After each plate is acquired 
on the main MetaXpress Software system, information regarding analysis 
of the plate is placed in a queue in the database. When other 
MetaXpress Software computers that are connected to the database are 
set in Auto Run Mode, they check the queue and run analyses on plates 
as the data becomes available.
Having separate computers to acquire and analyze your screening data 
significantly reduces the overall screening time by freeing up the main 
MetaXpress Software system to continue acquisition. You can also set up 
more than one MetaXpress Software computer to run in Auto Run Mode, 
further reducing the time it takes to process multiple plates.

To set up and use Auto Run Mode:
1. On the computer that is acquiring images, start the MetaXpress 

Software.
2. Click Screening > Plate Acquisition Setup. 

In the simplified menu structure, click Screening > Acquisition 
Setup.

3. In the Plate Acquisition Setup dialog, on the Acquisition tab, 
select Analyze Images After Acquisition, and then open the 
Analysis tab.

4. On the Analysis drop-down list, select the assay (application 
module, custom module, or journal assay) to run after 
acquisition.

5. Continue to set up and run your acquisition. After the plate is 
acquired, it is added to the Auto Run queue.

6. On the computer that is running the analysis, start the 
MetaXpress Software.

Note: When the MetaXpress Software is in Auto Run Mode, the 
application cannot be used for any other purpose.
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7. Click Screening > Start Auto Run Mode [DB].

8. In the Auto Run Mode dialog, to run the analysis on more than 
one plate, clear Leave auto run mode when plate is finished. If 
this option is selected, then only one plate is analyzed. 

9. After the analysis is completed for all plates, click Cancel to close 
the Auto Run Mode dialog. 

Note: To use the system for other tasks and prevent the 
MetaXpress Software from starting the analysis on the next 
plate after it is finished with the plate that it is currently 
analyzing, then Leave auto run mode when plate is finished 
must be selected. While in Auto Run Mode, all other 
MetaXpress Software options are disabled.

Note: Data from sites analyzed remains in the database, but the 
plate is removed from the Auto Run queue.
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Monitoring the Status of Automated Analyses
1. On the computer that is running the analysis, click the Screening 

> Auto Run Plate Statuses [DB].
Alternatively, click Screening > Start Auto Run Mode [DB], and 
then in the Auto Run Mode dialog, click Status.

The following statuses are possible:
 Running indicates that the analysis is currently running on 

the plate. After the analysis is completed for the plate, the 
plate is removed from the auto run plate status list.

 Timeout indicates that the analysis has not completed on a 
well or site in the expected time. The maximum time allowed 
for analysis is set in the MDCStoreToolsTM Data Management 
Utility with the Set Auto Run Timeout option. A timeout is 
generally caused by an error on the computer running the 
analysis. To diagnose the cause of the timeout, inspect the 
computer that has timed out for error messages or other 
problems. In some situations, the problem can be resolved 
and the analysis can continue. If this happens, the status is 
reset to Running. In other situations, the Auto Run must be 
canceled and the analyses run again. Some analyses, 
particularly custom modules or journal analyses, take a long 
time to complete. For these situations, increase the timeout 
value for the Set Auto Run Timeout option to allow enough 
time to run and complete the analysis.

 Pending indicates the analysis has not yet started on the 
plate.

Note: The Auto Run Plate Statuses dialog also shows any plates 
to be analyzed from the Review Plate Data dialog. However, 
computers in Auto Run Mode do not claim these plates.
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 Acquiring indicates that the plate is currently being acquired. 
Analysis does not happen until after the acquisition is 
complete.

 Error indicates an error in the analysis and that the analysis 
was unable to be completed as a result, for example, analysis 
settings that were defined for different wavelengths than 
those that are available on the plate.

2. Optionally, do one of the following as required:
 To stop running an analysis on a plate, select the plate from 

the table in the Auto Run Plate Statuses dialog, and click 
Cancel Selected Plate.

 To stop running the analysis on all plates, click Cancel All 
Plates.
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Batch Analysis
Although the MetaXpress® Software provides features for automating 
analyses with image acquisition, you can use the Plate Data Utilities 
dialog to manually initiate an analysis on more than one plate at a time. 

1. Click Screening > Plate Data Utilities.
In the simplified menu structure, click Screening > Plate Utilities.

2. In the Plate Data Utilities dialog, click Run Analysis. 
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3. In the Select Plates for Analysis dialog, use the query tools or 
expand a folder so that several plates open in the bottom 
window.

4. Select a plate or use Ctrl+Click or Shift+Click to select multiple 
plates.

5. Click Select.
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6. In the Run Analysis on Plates dialog, on the Analysis drop-down 
list, select the assay to run.

7. On the Settings drop-down list, select the appropriate setting.
8. Select a Run method:
 Select Run now on this computer to start the analysis only 

on this computer.
 Select Add to auto run list to add the job to the autorun 

queue to run on other computers that are in autorun mode, 
or to run with the MetaXpress® PowerCoreTM Software.

9. If you selected Run now on this computer, then on the Images 
to open for the analysis drop-down list, select the wavelengths 
to use with the selected assay.

Note: If you select Add to auto run list, you must also start the 
Auto Run mode that is available on the Screening menu, or the 
MetaXpress PowerCore Software must be running. The 
MetaXpress PowerCore Software processes application modules 
and custom modules, but it does not process journals. 
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10. If the plate contains multiple time points, then select from the 
Timelapse options:
 All time points analyses all acquisition time points.
 Time point range analyzes the time points that are in the 

defined range. To use a single time point, type the same time 
point in both fields.

 Stack of time points is available when you select a time 
lapse journal that analyzes planes in a stack as separate time 
points from the Analysis drop-down list.

11. If the plate contains Z data, then select from the Z Steps options:
 All Z steps analyzes all the acquisition planes.
 Z step range analyzes only those planes that fall within the 

defined range. To use a single Z step, type the same step 
value in both fields.

 Stack of all Z steps is available when the selected analysis is 
a journal.

 2D projection analyzes only the two-dimensional projection 
image.

12. Click OK. 
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Managing Plate Data
Use the Plate Data Utilities dialog to manage the images and data that 
were acquired during plate acquisition.

This chapter includes the following topics:
• Importing Images on page 120
• Importing Cellomics Data on page 121
• Exporting Measurements through a Query on page 123
• Exporting Images on page 130
• Deleting Measurements on page 130
• Deleting Images on page 131
• Deleting Plates on page 132

Note: The Delete Measurements, Delete Images, and Delete Plates 
options mark data for deletion, but they do not delete the data from 
the database or fileserver. To permanently remove the data from the 
database or fileserver, use the MDCStoreToolsTM Data Management 
Utility. For more information, see the MDCStoreToolsTM Data 
Management Utility User Guide. 
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Importing Images
Use the Import Images option to import one or more data sets created 
by other Meta Imaging Series® applications into the configured image 
storage location in the MDCStore database. Only images that have been 
saved with the appropriate file naming conventions and with an 
associated HTD file can be imported. The data is then accessible using 
either the Plate Data Utilities dialog or the Review Plate Data dialog. You 
can also use these dialogs to import a plate of Cellomics DIB files into the 
MDCStore fileserver or database. See Importing Cellomics Data on 
page 121.

1. In the Plate Data Utilities dialog, click Import Images. 
2. In the Import Images dialog, click Select Directory.
3. In the Browse for Folder dialog, navigate to the local or network 

folder containing the data sets to import, and then click OK. 
The path is displayed next to the Select Directory button and the 
HTD files are displayed in the HTD Files field.

4. To select the data sets to import, in the HTD Files pane, select 
the check boxes next to the HTD files.

5. On the Move images drop-down list, select a location (either the 
fileserver, a UNC path location, or the database) to which to 
import the data sets.

Note: For information about the Run Analysis option on the Plate Data 
Utilities dialog, see Chapter 9: Batch Analysis on page 115. 

Note: To import third-party images or images with varying file name 
conventions into the MDCStore database, use the MDCStoreTM Xchange 
Data Conversion Service that is available as an optional component of 
the MetaXpress Software installation. 

Note: The locations in this list are configured using the 
MDCStoreToolsTM Data Management Utility. 
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6. Click Import. 
The files are imported and are available for review in the Review 
Plate Data dialog.

Importing Cellomics Data
Use the Import Special option on the Import Images dialog to convert 
sets of Cellomics DIB files into data sets in the database that can be 
accessed using either the Plate Data Utilities dialog or the Review Plate 
Data dialog. The Import Special option creates MetaXpress HTD files 
based on the data in the DIB files and converts the images to the TIFF 
format. It then moves the data into your MetaXpress Software screening 
database or a selected local or network folder.

Note: Depending on the number of files being imported, this 
step can take several minutes to complete.

Note: You can also import third-party images into the MDCStore 
database using the MDCStoreTM Xchange Data Conversion Service that 
is available as an optional component of the MetaXpress Software 
installation. 

Note: Cellomics DIB files do not include image calibration data. Unless 
you define a specific calibration when you import the data, a default 
calibration of 1 μm = 1 pixel is applied to the imported images.
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To import cellomics data
1. In the Plate Data Utilities dialog, click Import Images, and then 

click Import Special.

2. In the Import Special dialog, click Select Directory. 

3. In the Browse for Folder dialog, navigate to the local or network 
folder containing the Cellomics data to be imported, and then 
click OK. 
The path is displayed next to the Select Directory button and the 
Cellomics files are displayed in the Data sets pane.

4. Select the check box next to the Cellomics file set to be 
imported.

Note: To convert the sets of Cellomics DIB files that are 
contained in the selected directory and below, make sure that 
Include subdirectories is selected. 
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5. On the Store images in drop-down list, select a location (either 
the database or an available network folder) to which to import 
the Cellomics data.

6. In the Image calibration section, type a calibration ratio (μm per 
pixel) for the x and y values of the imported images.

7. Click Import. 
The files are imported and are available for review in the Plate 
Data Utilities or Review Plate Data dialog.

Exporting Measurements through a Query
The Export Measurements option exports selected data of one or more 
measurement sets to a text file. The Export Measurements wizard 
provides a query builder that helps you select the data to export. For 
example, of all the cell data in a measurement set, you might want to 
export data only from cells with a nuclear intensity greater than some 
threshold, or out of all the image data, you might want to export data 
only from images where the number of cells is above some threshold.
Two methods for constructing a query are available: Simple and 
Advanced. The main difference between the two methods is how you 
select or specify the measurement sets:

• Simple Query: To create a Simple query, select the measurement 
sets from a list. 

• Advanced Query: To create an Advanced query, specify the 
attribute criteria that identify the measurement sets, for 
example, measurement sets that contain data for plates acquired 
on a certain date. To create an Advanced query, you must know 
some of the unique attributes that identify the measurement 
sets containing data that you want to export such as the date 
created, the creator name, or name, or the plate information 
that is contained in the measurement set such as date annotated 
or global ID.

Note: The default calibration is 1 μm = 1 pixel.
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When using the Export Measurements wizard, keep in mind the 
following:

• On both the Step 1 page and the Step 2 page of the wizard, the 
pane on the left contains the measurement sets or data types 
that can be queried, and the pane on the right displays the query 
as you build it.

• In the Query pane, multiple measurement-set queries are 
combined with an OR by default, causing all selected 
measurement sets to be included.

• In the Query pane, multiple data-type queries are combined with 
an AND by default, requiring that all defined conditions are met 
at the same time.

• To change the way queries are combined (known as Boolean 
expressions), in the Query pane, use Ctrl-click or Shift-click to 
select the individual queries for measurement sets or data types, 
and then click OR or AND. To undo or separate a combination, 
select the Boolean expression, and click Break Up. 

• To remove an expression from the Query pane, select the 
expression, and then click Remove.

• To save the query for later use, click Save. To load a query that 
was saved earlier, click Load.

To construct a query
1. Click Screening > Plate Data Utilities.

In the simplified menu structure, click Screening > Plate Utilities.
2. In the Plate Data Utilities dialog, click Export Measurements.
3. Select the type of measurement data to export: Cell 

Measurements, Image Measurements, or Cell and Image 
Measurements, and then click OK.

4. On the Export Measurements Wizard - Step 1 page, do one of 
the following:
 Select Simple Query, and then continue to To construct a 

Simple query
 Select Advanced Query, and then continue to To construct 

an Advanced query on page 126.
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To construct a Simple query
1. In the top left pane, double-click the Measurement Set folder 

that contains the data to export.
The measurement set attributes are displayed in a “tree view” in 
the upper-left pane and the measurement set is added to the list 
in the lower-left pane. For example:

2. In the lower-left pane, select the measurement sets that contain 
the data to export, and then click the arrow between the panes 
to add the measurement sets to the Query pane.

Note: The attributes are displayed for informational purposes 
only to help you identify the measurement sets. You select the 
data types to export on the next page of the wizard.

Note: To add, remove, or rearrange columns in the lower left 
pane, click the Configure Columns button. In the dialog that 
appears, use Ctrl-click or Shift-click to select columns, and then 
click an arrow between the panes to move the columns.
5039429 C 125 



MetaXpress High Content Image Acquisition & Analysis Software Analysis Guide

MX_AnalysisGuide.book  Page 126  Wednesday, April 13, 2016  11:05 AM
3. When all the measurement sets containing the data to export 
are listed in the Query pane, click Next.

4. Click Finish.
5. Continue to To configure the data for export on page 128 for 

instructions on specifying how the data appears in the text file.

To construct an Advanced query
1. In the top left pane, expand the Measurement Sets folder, and 

then expand a folder that contains the measurement set 
attributes. For example:

Tip: To quickly add all measurement sets to the lower left pane, 
double-click the top-level Measurement Set folder in the top 
left pane. Then, in the lower left pane, use Ctrl-click or Shift-click 
to select measurement sets to add to the query.
126 5039429 C 



Managing Plate Data

MX_AnalysisGuide.book  Page 127  Wednesday, April 13, 2016  11:05 AM
2. Double-click the attribute that identifies the measurement sets 
for the query, and then in the New Query dialog, select an 
operator and type a value to filter the data that to export, and 
then click OK.
For example, to export just those measurement sets that contain 
data for plates acquired on February 20, 2015, expand the Plate 
Info branch, double-click Date Created, select “=” for the 
Operator, and then in the Value field, select the date.

3. Repeat Step 2 as required to include all the criteria that identifies 
the measurement sets containing the data to export in the 
Query pane.

4. Click Next.
5. On the Export Measurements Wizard - Step 2 page, expand the 

Data Types folder, expand a subfolder, and then double-click the 
type of data to export.

6. To define the criteria for the data to export for the selected data 
type, in the New Query dialog, select an operator and a value.
For example, to export measurements that contain a total nuclei 
count of more than 20, select “>” for the Operator, and then in 
the Value field, type 20.

7. Click OK.
The query statement that defines the data that to export for the 
selected data type is added to the Query pane.

8. Repeat Step 5 through Step 7 to add as many data types as 
needed to the query.

9. Click Finish.
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10. Continue to To configure the data for export for instructions on 
specifying how the data appears in the text file.

To configure the data for export
After you have used the wizard to configure the query, the Configure 
Data Export dialog opens. Use this dialog to specify the data display in 
the text file, and then export the data.

1. In the Rows pane, select the data type to display in rows in the 
text file such as sites, compounds, plates, cells, or wells, and then 
click the arrow to move the data type to the right pane.

2. In the Columns pane, select the measurement type to display in 
columns for each data type such as total nuclei, total cell area, 
average intensity, and then click the arrow to move the 
measurement type to the right pane.

3. To calculate a statistic for the exported data (for example, if you 
are averaging the data for multiple cells or wells), then on the 
Apply Calculations drop-down list, select the statistic. 
Otherwise, leave the value set to None. 
The Data Layout View pane shows how the data is to be 
displayed in the text file.

4. Click OK.
The Export as text file dialog opens. The dialog lists the 
measurement sets that contain the data to export. By default, 
the data for each measurement set is saved as a separate text file 
with a system-generated file name.

Note: To resize the width of the columns, drag the column 
headings or right-click and select Fit Columns. To sort the data in 
a column in ascending or descending order, click once in the 
column heading. To reorder the items in the right panes, click 
the up and down arrows.
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5. Do one or more of the following as required:
 Optionally, to change the name of the system-generated file 

name, select the file name in the list, and then click the Edit 

File Name button .
 To combine the measurement data for all measurement sets 

into one text file, select Export all measurements to one file, 
and then in the File Name field, type a file name.

 To include information in the header of the text file such as 
the plate name, date the measurement set was created, or 
the plate description, click the Configure Columns button 

, and in the Select Display Columns dialog, use Ctrl-click 
or Shift-click to select columns, and then click an arrow 
between the panes to move the columns.

6. Click OK.
The data is saved in the text file or text files, and the Export 
Measurement Set Summary dialog opens.

7. Optionally, to create a separate text file that contains the 
computer name, destination folder, number of files, and file 
names related to the export, click Save Summary.

8. Click Close.
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Exporting Images
To export images to a local or networked folder, do the following:

1. Click Screening > Plate Data Utilities. 
In the simplified menu structure, click Screening > Plate Utilities.

2. In the Plate Data Utilities dialog, click Export Images to export 
images. 

3. In the upper pane of the Select Plate for Export dialog, expand 
the Plate folder to view folders containing plates saved to the 
database.

4. Double-click a folder to view its name, date created, creator, and 
barcode (if applicable) on the lower pane.

5. In the lower pane, select the plate that to export, and then click 
Select. 

6. In the Browse for Folder dialog, navigate to the local or 
networked folder to which to export the images, and then click 
OK. 
The acquired images (TIF), thumbnail images (TIF), and the 
associated experiment plate information file (HTD) are exported.

Deleting Measurements
To delete measurements from a plate, you must first delete them using 
the Delete Measurements option. After you use the Delete 
Measurements option, you must then use the MDCStoreTools Data 
Management Utility to permanently remove the measurements or a 
selected measurement from the database or fileserver. See the 
MDCStoreToolsTM Data Management Utility User Guide for more 
information. 

Note: The Delete Measurements option deletes all the measurement 
sets that are associated with a plate. To delete just one measurement 
set from a plate, use the Manage Measurement Set option in the 
MDCStoreTools Data Management Utility. For more information, see 
the MDCStoreToolsTM Data Management Utility User Guide.
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To delete measurements
1. Click Screening > Plate Data Utilities. 

In the simplified menu structure, click Screening > Plate Utilities.
2. In the Plate Data Utilities dialog, click Delete Measurements.
3. In the upper pane of the Select Plates for Measurement 

Deletion dialog, expand the Plate folder to view the folders that 
contain plates that have been saved to the database.

4. Double-click the appropriate folder to display all the plates and 
their associated information (name, date created, creator, and 
barcode (if applicable)) that are contained in the folder in lower 
pane.

5. In the lower pane, select the plate (use Shift+click or CTRL+click 
to select multiple plates) that contains the measurements to 
delete, click Select, and then click OK.

6. In the Plate Data Utilities message, click OK to delete all the 
measurements from the selected data sets.

Deleting Images
To delete images from a plate, you must first delete them using the 
Delete Images option. After you use the Delete Images option, you must 
then use the MDCStoreTools Data Management Utility to permanently 
remove the images from the database or fileserver. See the 
MDCStoreToolsTM Data Management Utility User Guide for more 
information. The image measurements and data remain in the database.

Note: This step does not remove the data from the database or 
fileserver. To remove the data from the database or fileserver, 
you must use the MDCStoreTools Data Management Utility. For 
more information, see the MDCStoreToolsTM Data Management 
Utility User Guide.

Note: If you delete only the images from a plate that has been analyzed 
and contains data and not the measurements or the plate itself, then 
you can still use the Review Plate Data dialog to view the data from the 
plate.
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To delete images from a plate
1. Click Screening > Plate Data Utilities. 

In the simplified menu structure, click Screening > Plate Utilities.
2. In the Plate Data Utilities dialog, click Delete Images.
3. In the upper pane of the Select Plates for Image Deletion dialog, 

expand the Plate folder to view folders that contains plates that 
have been saved to the database.

4. Double-click the appropriate folder to display all the plates and 
their associated information (name, date created, creator, and 
barcode (if applicable)) that are contained in the folder in lower 
pane.

5. In the lower pane, select the plate (use Shift+click or CTRL+click 
to select multiple plates) that contains the images to delete, click 
Select, and then click OK.

6. In the Plate Data Utilities message, click OK to delete all the 
images from the selected data sets.

Deleting Plates
To delete plates from the database, you must first delete them using the 
Delete Plates option. After you use the Delete Plates option, you must 
then use the MDCStoreTools Data Management Utility to permanently 
remove the plates from the database or fileserver. If you create an 
archive or a backup of the images with the MDCSToreTools Data 
Management Utility, then you can retrieve the plates with the images, 
but not the measurements. For more information, see the 
MDCStoreToolsTM Data Management Utility User Guide.

Note: This step does not remove the images from the database 
or fileserver. You must use the MDCStoreTools Data 
Management Utility to permanently remove the images from 
the database or fileserver. See the MDCStoreToolsTM Data 
Management Utility User Guide for more information.

Note: You must have the appropriate security privileges to select plates 
for deletion. Deleting plates deletes related images and measurements.
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To delete a plate
1. Click Screening > Plate Data Utilities. 

In the simplified menu structure, click Screening > Plate Utilities.
2. In the Plate Data Utilities dialog, click Delete Plates. 
3. In the upper pane of the Select Plates for Deletion dialog, 

expand the Plate folder to view folders containing plates saved 
to the database.

4. Double-click a folder to view its name, date created, creator, and 
barcode (if applicable) on the lower pane.

5. Use Ctrl+click or Shift+click to select the plates to delete from the 
lower pane, click Select, and then click OK.

6. In the Plate Data Utilities message, click OK to delete all the 
selected plates.

Note: This step removes the data from the Select Plate for 
Deletion dialog but not from the database or fileserver. To 
permanently remove the data from the database or fileserver, 
you must use the MDCStoreTools Data Management Utility. For 
more information, see the MDCStoreToolsTM Data Management 
Utility User Guide.
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